mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Eric Paris <eparis@redhat.com>
To: Richard Guy Briggs <rgb@redhat.com>
Cc: linux-audit@redhat.com, linux-kernel@vger.kernel.org,
	sgrubb@redhat.com, aviro@redhat.com, pmoore@redhat.com
Subject: Re: [PATCH 5/7] audit: remove redundant watch refcount
Date: Fri, 10 Oct 2014 15:44:20 -0400	[thread overview]
Message-ID: <1412970260.15099.8.camel@redhat.com> (raw)
In-Reply-To: <ab6cab591e00ed03bbde0467c42ca59879baaca7.1412285491.git.rgb@redhat.com>

Having a hard time convincing myself of the next 2...  Doesn't mean
they're wrong or bad, but my brain isn't seeing it today...

On Thu, 2014-10-02 at 22:05 -0400, Richard Guy Briggs wrote:
> Remove extra layer of audit_{get,put}_watch() calls.
> 
> Signed-off-by: Richard Guy Briggs <rgb@redhat.com>
> ---
>  kernel/audit_watch.c |    5 +----
>  kernel/auditfilter.c |    7 -------
>  2 files changed, 1 insertions(+), 11 deletions(-)
> 
> diff --git a/kernel/audit_watch.c b/kernel/audit_watch.c
> index f209448..c707afb 100644
> --- a/kernel/audit_watch.c
> +++ b/kernel/audit_watch.c
> @@ -203,7 +203,6 @@ int audit_to_watch(struct audit_krule *krule, char *path, int len, u32 op)
>  	if (IS_ERR(watch))
>  		return PTR_ERR(watch);
>  
> -	audit_get_watch(watch);
>  	krule->watch = watch;
>  
>  	return 0;
> @@ -306,7 +305,6 @@ static void audit_update_watch(struct audit_parent *parent,
>  				 * new watch.
>  				 */
>  				audit_put_watch(nentry->rule.watch);
> -				audit_get_watch(nwatch);
>  				nentry->rule.watch = nwatch;
>  				list_add(&nentry->rule.rlist, &nwatch->rules);
>  				list_add_rcu(&nentry->list, &audit_inode_hash[h]);
> @@ -392,8 +390,7 @@ static void audit_add_to_parent(struct audit_krule *krule,
>  
>  		watch_found = 1;
>  
> -		/* put krule's and initial refs to temporary watch */
> -		audit_put_watch(watch);
> +		/* put krule's ref to temporary watch */
>  		audit_put_watch(watch);
>  
>  		audit_get_watch(w);
> diff --git a/kernel/auditfilter.c b/kernel/auditfilter.c
> index facd704..5675916 100644
> --- a/kernel/auditfilter.c
> +++ b/kernel/auditfilter.c
> @@ -563,8 +563,6 @@ exit_nofree:
>  	return entry;
>  
>  exit_free:
> -	if (entry->rule.watch)
> -		audit_put_watch(entry->rule.watch); /* matches initial get */
>  	if (entry->rule.tree)
>  		audit_put_tree(entry->rule.tree); /* that's the temporary one */
>  	audit_free_rule(entry);
> @@ -942,8 +940,6 @@ static inline int audit_add_rule(struct audit_entry *entry)
>   	return 0;
>  
>  error:
> -	if (watch)
> -		audit_put_watch(watch); /* tmp watch, matches initial get */
>  	return err;
>  }
>  
> @@ -951,7 +947,6 @@ error:
>  static inline int audit_del_rule(struct audit_entry *entry)
>  {
>  	struct audit_entry  *e;
> -	struct audit_watch *watch = entry->rule.watch;
>  	struct audit_tree *tree = entry->rule.tree;
>  	struct list_head *list;
>  	int ret = 0;
> @@ -992,8 +987,6 @@ static inline int audit_del_rule(struct audit_entry *entry)
>  	mutex_unlock(&audit_filter_mutex);
>  
>  out:
> -	if (watch)
> -		audit_put_watch(watch); /* match initial get */
>  	if (tree)
>  		audit_put_tree(tree);	/* that's the temporary one */
>  



  reply	other threads:[~2014-10-10 19:44 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-10-02 21:38 [PATCH 0/7] audit fsnotify cleanups for watches and trees Richard Guy Briggs
2014-10-03  2:05 ` [PATCH 1/7] audit: put rule existence check in canonical order Richard Guy Briggs
2014-10-03  2:05 ` [PATCH 2/7] audit: cull redundancy in audit_rule_change Richard Guy Briggs
2014-10-10 19:09   ` Eric Paris
2014-10-03  2:05 ` [PATCH 3/7] audit: eliminate string copy for new tree rules Richard Guy Briggs
2014-10-10 19:13   ` Eric Paris
2014-10-03  2:05 ` [PATCH 4/7] audit: optimize add to parent skipping needless search and consuming parent ref Richard Guy Briggs
2014-10-10 19:29   ` Eric Paris
2014-10-03  2:05 ` [PATCH 5/7] audit: remove redundant watch refcount Richard Guy Briggs
2014-10-10 19:44   ` Eric Paris [this message]
2014-10-03  2:05 ` [PATCH 6/7] audit: remove extra audit_get_parent() Richard Guy Briggs
2014-10-03  2:05 ` [PATCH 7/7] audit: rename audit_log_remove_rule to disambiguate for trees Richard Guy Briggs

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1412970260.15099.8.camel@redhat.com \
    --to=eparis@redhat.com \
    --cc=aviro@redhat.com \
    --cc=linux-audit@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pmoore@redhat.com \
    --cc=rgb@redhat.com \
    --cc=sgrubb@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome