mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Joe Perches <joe@perches.com>
To: Fabian Frederick <fabf@skynet.be>
Cc: linux-kernel@vger.kernel.org, Jens Axboe <axboe@kernel.dk>
Subject: Re: [PATCH 7/8] cdrom: cdrom: export sysctl code
Date: Fri, 31 Oct 2014 15:12:34 -0700	[thread overview]
Message-ID: <1414793554.13647.5.camel@perches.com> (raw)
In-Reply-To: <1414792084-7739-8-git-send-email-fabf@skynet.be>

On Fri, 2014-10-31 at 22:48 +0100, Fabian Frederick wrote:
> -Move all sysctl operations to cdrom_sysctl
> -Remove static/add extern in cdrom.h for some variables
> -Rename debug to cdrom_debug
> -Fix some checkpatch warnings
> -Update cdrom makefile accordingly.
[]
> diff --git a/include/linux/cdrom.h b/include/linux/cdrom.h
[]
> +extern bool cdrom_debug;
> +extern bool autoclose;
> +extern bool autoeject;
> +extern bool lockdoor;
> +extern bool check_media_type;
> +extern bool mrw_format_restart;
> +extern struct list_head cdrom_list;
> +extern struct mutex cdrom_mutex;

I think these should be prefixed with "cdrom_"



  reply	other threads:[~2014-10-31 22:12 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-10-31 21:47 [PATCH 0/8] cdrom: sysctl export + clean-up Fabian Frederick
2014-10-31 21:47 ` [PATCH 1/8] cdrom: include linux/uaccess.h instead of asm/uaccess.h Fabian Frederick
2014-10-31 21:47 ` [PATCH 2/8] cdrom: use static const char * const where possible Fabian Frederick
2014-10-31 21:47 ` [PATCH 3/8] cdrom: fix spaces required errors Fabian Frederick
2014-10-31 21:48 ` [PATCH 4/8] cdrom: move EXPORT_SYMBOL after functions Fabian Frederick
2014-10-31 21:48 ` [PATCH 5/8] cdrom: remove bool comparison/assignment to 0/1 Fabian Frederick
2014-10-31 21:48 ` [PATCH 6/8] cdrom: use bool for true/false initialized variable Fabian Frederick
2014-10-31 21:48 ` [PATCH 7/8] cdrom: cdrom: export sysctl code Fabian Frederick
2014-10-31 22:12   ` Joe Perches [this message]
2014-10-31 21:48 ` [PATCH 8/8] cdrom: fix init_cdrom_command in dvd_do_auth Fabian Frederick

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1414793554.13647.5.camel@perches.com \
    --to=joe@perches.com \
    --cc=axboe@kernel.dk \
    --cc=fabf@skynet.be \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome