From: Joe Perches <joe@perches.com>
To: Pablo Neira Ayuso <pablo@netfilter.org>
Cc: Steven Rostedt <rostedt@goodmis.org>,
linux-kernel@vger.kernel.org, Al Viro <viro@ZenIV.linux.org.uk>,
Andrew Morton <akpm@linux-foundation.org>,
Patrick McHardy <kaber@trash.net>,
Jozsef Kadlecsik <kadlec@blackhole.kfki.hu>,
netfilter-devel@vger.kernel.org, coreteam@netfilter.org
Subject: Re: [PATCH 3/8] netfilter: Convert print_tuple functions to return void
Date: Wed, 05 Nov 2014 15:26:34 -0800 [thread overview]
Message-ID: <1415229994.6634.35.camel@perches.com> (raw)
In-Reply-To: <20141105232314.GA3195@salvia>
On Thu, 2014-11-06 at 00:23 +0100, Pablo Neira Ayuso wrote:
> On Wed, Nov 05, 2014 at 02:24:29PM -0500, Steven Rostedt wrote:
> > From: Joe Perches <joe@perches.com>
> >
> > Since adding a new function to seq_file (seq_has_overflowed())
> > there isn't any value for functions called from seq_show to
> > return anything. Remove the int returns of the various
> > print_tuple/<foo>_print_tuple functions.
[]
> I replied to this yesterday, but it seems some spam filter also
> munched it. One comment below.
>
> > @@ -202,9 +203,8 @@ static int ct_seq_show(struct seq_file *s, void *v)
> > if (l4proto->print_conntrack)
> > l4proto->print_conntrack(s, ct);
> >
> > - if (print_tuple(s, &ct->tuplehash[IP_CT_DIR_ORIGINAL].tuple,
> > - l3proto, l4proto))
> > - goto release;
> > + print_tuple(s, &ct->tuplehash[IP_CT_DIR_ORIGINAL].tuple,
> > + l3proto, l4proto);
> >
> > if (seq_print_acct(s, ct, IP_CT_DIR_ORIGINAL))
> > goto release;
>
> seq_print_acct returns seq_printf which is now void. I guess you have
> to remove this check too.
seq_printf shouldn't be void yet.
There are still other places that need conversion.
> > if (seq_print_acct(s, ct, IP_CT_DIR_REPLY))
> > goto release;
>
> And here.
Eventually I trust it will be fixed, but these
patches are an intermediate step on the way there.
next prev parent reply other threads:[~2014-11-05 23:26 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-11-05 19:24 [PATCH 0/8] [GIT PULL] seq_file: Add seq_has_overflowed() and start using it Steven Rostedt
2014-11-05 19:24 ` [PATCH 1/8] seq_file: Rename seq_overflow() to seq_has_overflowed() and make public Steven Rostedt
2014-11-05 19:24 ` [PATCH 2/8] netfilter: Remove return values for print_conntrack callbacks Steven Rostedt
2014-11-05 19:24 ` [PATCH 3/8] netfilter: Convert print_tuple functions to return void Steven Rostedt
2014-11-05 23:23 ` Pablo Neira Ayuso
2014-11-05 23:26 ` Joe Perches [this message]
2014-11-05 19:24 ` [PATCH 4/8] netfilter: Remove checks of seq_printf() return values Steven Rostedt
2014-11-05 19:24 ` [PATCH 5/8] dlm: Remove seq_printf() return checks and use seq_has_overflowed() Steven Rostedt
2014-11-05 19:24 ` [PATCH 6/8] dlm: Use seq_puts() instead of seq_printf() for constant strings Steven Rostedt
2014-11-05 19:24 ` [PATCH 7/8] fs: Convert show_fdinfo functions to void Steven Rostedt
2014-11-05 19:24 ` [PATCH 8/8] debugfs: Have debugfs_print_regs32() return void Steven Rostedt
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1415229994.6634.35.camel@perches.com \
--to=joe@perches.com \
--cc=akpm@linux-foundation.org \
--cc=coreteam@netfilter.org \
--cc=kaber@trash.net \
--cc=kadlec@blackhole.kfki.hu \
--cc=linux-kernel@vger.kernel.org \
--cc=netfilter-devel@vger.kernel.org \
--cc=pablo@netfilter.org \
--cc=rostedt@goodmis.org \
--cc=viro@ZenIV.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome