From: Mariusz Gorski <marius.gorski@gmail.com>
To: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Willy Tarreau <willy@meta-x.org>
Cc: devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org
Subject: [PATCH 4/4] staging: panel: Use better names for two defined values
Date: Wed, 12 Nov 2014 02:08:09 +0100 [thread overview]
Message-ID: <1415754489-9097-5-git-send-email-marius.gorski@gmail.com> (raw)
In-Reply-To: <1415754489-9097-1-git-send-email-marius.gorski@gmail.com>
Give DEFAULT_KEYPAD and DEFAULT_LCD defines better names,
so that their meaning is emphasized.
Signed-off-by: Mariusz Gorski <marius.gorski@gmail.com>
---
drivers/staging/panel/panel.c | 16 ++++++++--------
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/panel/panel.c b/drivers/staging/panel/panel.c
index 05b0d1e..c6eeddf 100644
--- a/drivers/staging/panel/panel.c
+++ b/drivers/staging/panel/panel.c
@@ -304,8 +304,8 @@ static unsigned char lcd_bits[LCD_PORTS][LCD_BITS][BIT_STATES];
*/
#define DEFAULT_PARPORT 0
#define DEFAULT_PROFILE PANEL_PROFILE_LARGE
-#define DEFAULT_KEYPAD KEYPAD_TYPE_OLD
-#define DEFAULT_LCD LCD_TYPE_OLD
+#define DEFAULT_KEYPAD_TYPE KEYPAD_TYPE_OLD
+#define DEFAULT_LCD_TYPE LCD_TYPE_OLD
#define DEFAULT_LCD_HEIGHT 2
#define DEFAULT_LCD_WIDTH 40
#define DEFAULT_LCD_BWIDTH 40
@@ -332,13 +332,13 @@ static unsigned char lcd_bits[LCD_PORTS][LCD_BITS][BIT_STATES];
#if DEFAULT_PROFILE == 0 /* custom */
#ifdef CONFIG_PANEL_KEYPAD
-#undef DEFAULT_KEYPAD
-#define DEFAULT_KEYPAD CONFIG_PANEL_KEYPAD
+#undef DEFAULT_KEYPAD_TYPE
+#define DEFAULT_KEYPAD_TYPE CONFIG_PANEL_KEYPAD
#endif
#ifdef CONFIG_PANEL_LCD
-#undef DEFAULT_LCD
-#define DEFAULT_LCD CONFIG_PANEL_LCD
+#undef DEFAULT_LCD_TYPE
+#define DEFAULT_LCD_TYPE CONFIG_PANEL_LCD
#endif
#ifdef CONFIG_PANEL_LCD_HEIGHT
@@ -2239,9 +2239,9 @@ static int panel_init(void)
case PANEL_PROFILE_CUSTOM:
/* custom profile */
if (keypad_type < 0)
- keypad_type = DEFAULT_KEYPAD;
+ keypad_type = DEFAULT_KEYPAD_TYPE;
if (lcd_type < 0)
- lcd_type = DEFAULT_LCD;
+ lcd_type = DEFAULT_LCD_TYPE;
break;
case PANEL_PROFILE_OLD:
/* 8 bits, 2*16, old keypad */
--
2.1.3
next prev parent reply other threads:[~2014-11-12 1:10 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-11-12 1:08 [PATCH 0/4] staging: panel: Module parameters clean-up Mariusz Gorski
2014-11-12 1:08 ` [PATCH 1/4] staging: panel: Reorder initial DEFAULT_* defines Mariusz Gorski
2014-11-12 1:08 ` [PATCH 2/4] staging: panel: Reorder DEFAULT_* values redefines Mariusz Gorski
2014-11-12 1:08 ` [PATCH 3/4] staging: panel: Reorder module parameter declarations Mariusz Gorski
2014-11-12 1:08 ` Mariusz Gorski [this message]
2014-11-12 5:29 ` [PATCH 0/4] staging: panel: Module parameters clean-up Willy Tarreau
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1415754489-9097-5-git-send-email-marius.gorski@gmail.com \
--to=marius.gorski@gmail.com \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=willy@meta-x.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®