mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: <thloh@altera.com>
To: <dinguyen@altera.com>, <robh+dt@kernel.org>, <pawel.moll@arm.com>,
	<mark.rutland@arm.com>, <ijc+devicetree@hellion.org.uk>,
	<galak@codeaurora.org>, <devicetree@vger.kernel.org>,
	<linux-kernel@vger.kernel.org>, <linus.walleij@linaro.org>,
	<gnurou@gmail.com>, <grant.likely@linaro.org>,
	<akpm@linux-foundation.org>, <davem@davemloft.net>,
	<gregkh@linuxfoundation.org>, <joe@perches.com>,
	<mchehab@osg.samsung.com>, <crope@iki.fi>,
	<linux-gpio@vger.kernel.org>
Cc: <thloh.linux@gmail.com>, <thloh@altera.com>
Subject: [PATCH v10 0/2] drivers/gpio: Altera soft IP GPIO driver
Date: Tue, 24 Feb 2015 01:53:01 -0800	[thread overview]
Message-ID: <1424771583-4404-1-git-send-email-thloh@altera.com> (raw)

From: Tien Hock Loh <thloh@altera.com>

Adds a new device tree binding and driver for Altera soft GPIO IP.
The driver is able to do read/write and allows GPIO to be a interrupt controller.

Tested on Altera GHRD on interrupt handling and IO.

v10:
Updated conflicting device tree parameters
Removed unused headers
Used macro instead of magic numbers for ngpio
Code readability cleanup using ?: and temporal variables
Removed leftover garbage and unnecessary function calls
Checked bgpio_init but unusable because Altera GPIO may not be a multiple of 8 bits

v9:
Removed duplicated initialization on set_type using temporals to improve code readability in calling generic_handle_irq Using ?: ternary to reduce code size

v8:
Using for_each_set_bit
added const for struct definition
removed naggy pr_err
sort alpha header
remove unused macros
use fixed width data types instead of unsigned long whitespace issue fixes removed _relaxed function for better compatibility across different CPU changed irq_create_mapping to platform_get_irq updated implementation to use gpiochip_irqchip_add reserve interrupt-cells number 2 in device tree binding for future use remove confusing sections on devicetree bindings Added tristate Kconfig help text

v7:
used dev_warn instead of pr_warn
clean up unnecesarry if else indentation

v6:
Added irq_startup and irq_shutdown
changed bitwise clamping style
cleanup bitwise operation to improve readability change naming of mapped irqs from virq to mapped_irq

v5:
dispose irq_domain mapping correctly
update optional binding description in binding docs

v4:
added vendor prefix to devicetree binding for IP specific properties using MMIO GPIO helper library instead of manually map PIO to memory altera_gpio_chip inline struct documentation to kerneldoc using dev_ print to print a better failure message

v2, v3:
Do not reference NO_IRQ
Updated irq_set_type to only allow the hardware configured irq type


Tien Hock Loh (2):
  drivers/gpio: Altera soft IP GPIO driver device tree binding
  drivers/gpio: Altera soft IP GPIO driver

 .../devicetree/bindings/gpio/gpio-altera.txt       |  43 +++
 MAINTAINERS                                        |   6 +
 drivers/gpio/Kconfig                               |  10 +
 drivers/gpio/Makefile                              |   1 +
 drivers/gpio/gpio-altera.c                         | 374 +++++++++++++++++++++
 5 files changed, 434 insertions(+)
 create mode 100644 Documentation/devicetree/bindings/gpio/gpio-altera.txt
 create mode 100644 drivers/gpio/gpio-altera.c

-- 
1.7.11.GIT


             reply	other threads:[~2015-02-24  9:53 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-02-24  9:53 thloh [this message]
2015-02-24  9:53 ` [PATCH v10 1/2] drivers/gpio: Altera soft IP GPIO driver device tree binding thloh
2015-02-24  9:53 ` [PATCH v10 2/2] drivers/gpio: Altera soft IP GPIO driver thloh
2015-03-07 19:35 ` [PATCH v10 0/2] " Linus Walleij

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1424771583-4404-1-git-send-email-thloh@altera.com \
    --to=thloh@altera.com \
    --cc=akpm@linux-foundation.org \
    --cc=crope@iki.fi \
    --cc=davem@davemloft.net \
    --cc=devicetree@vger.kernel.org \
    --cc=dinguyen@altera.com \
    --cc=galak@codeaurora.org \
    --cc=gnurou@gmail.com \
    --cc=grant.likely@linaro.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=ijc+devicetree@hellion.org.uk \
    --cc=joe@perches.com \
    --cc=linus.walleij@linaro.org \
    --cc=linux-gpio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mark.rutland@arm.com \
    --cc=mchehab@osg.samsung.com \
    --cc=pawel.moll@arm.com \
    --cc=robh+dt@kernel.org \
    --cc=thloh.linux@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®