From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753705AbbCBKK5 (ORCPT ); Mon, 2 Mar 2015 05:10:57 -0500 Received: from mailout4.samsung.com ([203.254.224.34]:48130 "EHLO mailout4.samsung.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750824AbbCBKKo (ORCPT ); Mon, 2 Mar 2015 05:10:44 -0500 X-AuditID: cbfee691-f79b86d000004a5a-a4-54f43721179a From: Jaewon Kim To: linux-kernel@vger.kernel.org, devicetree@vger.kernel.org, linux-pm@vger.kernel.org, linux-input@vger.kernel.org Cc: Inki Dae , SangBae Lee , Rob Herring , Pawel Moll , Mark Rutland , Ian Campbell , Kumar Gala , Lee Jones , Chanwoo Choi , Sebastian Reichel , Beomho Seo , Jaewon Kim , Dmitry Torokhov Subject: [PATCH v7 0/5] Add new MFD driver for MAX77843 Date: Mon, 02 Mar 2015 19:10:33 +0900 Message-id: <1425291038-18269-1-git-send-email-jaewon02.kim@samsung.com> X-Mailer: git-send-email 1.7.9.5 X-Brightmail-Tracker: H4sIAAAAAAAAA+NgFmpikeLIzCtJLcpLzFFi42JZI2JSoKto/iXEoK/X1OL0p23sFte/PGe1 mH/kHKvF4UUvGC363yxktTj3aiWjxaT7E1gsdjQcYbW4//Uoo8XNT99YLS7vmsNm8bn3CKPF 0usXmSwmTF/LYtG69wi7xfFPB1ksTu8ucRD0WDNvDaPH5b5eJo+ds+6ye6xc/oXNY9OqTjaP O9f2sHn0bVnF6PF5k1wARxSXTUpqTmZZapG+XQJXxoO+r6wFfWIVZ05PZWlgnCrQxcjJISFg InF+6xUWCFtM4sK99WxdjFwcQgJLGSUuz2tmhin6uW0nM0RiEaPE/Dt3wRJCAm1MEuc2OIPY bALaEt/XL2YFsUUESiUaH95lBWlgFvjBLPF71iuwhLCAuUTTrOPsIDaLgKpE69vlQHEODl4B D4nJT41ATAkBBYk5k2xAWiUEHrFLzD/5jxmiXEDi2+RDLBA1shKbDkDdJilxcMUNlgmMggsY GVYxiqYWJBcUJ6UXmeoVJ+YWl+al6yXn525iBEbN6X/PJu5gvH/A+hCjAAejEg/vgnmfQ4RY E8uKK3MPMZoCbZjILCWanA+MzbySeENjMyMLUxNTYyNzSzMlcV4d6Z/BQgLpiSWp2ampBalF 8UWlOanFhxiZODilGhhFtyxnO80rbcTfwLPiBVP+DInirecZrf9Hmob8qVwxxds9uP7+nK0L eJLu3H2klZWROdn8LIfmzxQNncKIB0z5Kocvibbfm1T0o/sJ358v7/P4vz1zDLZ4wbeCc9rS X3/9nzq+mtVTNyfTeNG2y62Cy/PyNi0W3JHhu+nvRj3/9tzze4RMOo8osRRnJBpqMRcVJwIA vSy+J5UCAAA= X-Brightmail-Tracker: H4sIAAAAAAAAA+NgFjrDIsWRmVeSWpSXmKPExsVy+t9jAV1F8y8hBjPWaluc/rSN3eL6l+es FvOPnGO1OLzoBaNF/5uFrBbnXq1ktJh0fwKLxY6GI6wW978eZbS4+ekbq8XlXXPYLD73HmG0 WHr9IpPFhOlrWSxa9x5htzj+6SCLxendJQ6CHmvmrWH0uNzXy+Sxc9Zddo+Vy7+weWxa1cnm cefaHjaPvi2rGD0+b5IL4IhqYLTJSE1MSS1SSM1Lzk/JzEu3VfIOjneONzUzMNQ1tLQwV1LI S8xNtVVy8QnQdcvMAfpDSaEsMacUKBSQWFyspG+HaUJoiJuuBUxjhK5vSBBcj5EBGkhYw5jx oO8ra0GfWMWZ01NZGhinCnQxcnJICJhI/Ny2kxnCFpO4cG89WxcjF4eQwCJGifl37oIlhATa mCTObXAGsdkEtCW+r1/MCmKLCJRKND68ywrSwCzwg1ni96xXYAlhAXOJplnH2UFsFgFVida3 y4HiHBy8Ah4Sk58agZgSAgoScybZTGDkXsDIsIpRNLUguaA4KT3XSK84Mbe4NC9dLzk/dxMj OCafSe9gXNVgcYhRgINRiYfXY87nECHWxLLiytxDjBIczEoivK/lv4QI8aYkVlalFuXHF5Xm pBYfYjQF2j2RWUo0OR+YLvJK4g2NTcyMLI3MDS2MjM2VxHmV7NtChATSE0tSs1NTC1KLYPqY ODilGhit5BwmxEbOrP4Y+2+l2Hw2d7ZZIs2ruTjlz706l/nTft7fGZG6UVL6vmULVvSyWkn6 G6a6vl/Jy1TKf+5o4Zy4/fYWssse5lnxiwTt2+h3oudHyo+tr5tq5BUvP7PT8LS8/NzosPbX 4G2FRd9mqS0KW341NU/1iWb6673TBKJlvD/IT9g2Y4YSS3FGoqEWc1FxIgCmVJ3u3wIAAA== DLP-Filter: Pass X-MTR: 20000000000000000@CPGS X-CFilter-Loop: Reflected Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org This patch series adds MAX77843(Multi Function Device) driver. The MAX77843 includes MUIC(Micro USB Interface Controller), Li+ Charger with Fuel Gauge, 2 safeout LDOs for USB device and haptic controller using PWM. It is interfaced to host controller using I2C. Changes in v7: MFD Core - Fix indentation - Remove file name, MODULE information POWER - Fix typos Changes in v6: HAPTIC - fixed a situation where holding a Mutex return. Changes in v5: MFD Core - Use bracket in complex define. - Delete unnecessary letter '++' Charger - fix Kconfig merge conflict with Kernel version4.0 Changes in v4: MFD Core - Fix indentation - Add haptic register define in header HAPTIC - Add haptic driver Changes in v3: MFD Core - Fix wrong description and indentation in header. - Remove unnecessary variable. Regulator - Use ARRAY_SIZE() instead of define. Changes in v2: MFD Core - Fix charger regmap handle and typo. MUIC - Cleanup enum list. - Set path before send excon event. - Fix variable names and typos for readability. Charger - Remove unnecessary header. - Chnage error message more readable. - Remove unnecessary lines. Fuelgauge - Fix regmap_config and use regmap_read. - Add i2c_unregister_device function on *_remove function. - Fix typo in Kconfig. Doc - Remove unnecessary lines. - Add example of charger regulator.Beomho Seo (2): Jaewon Kim (3): mfd: max77843: Add max77843 MFD driver core driver Input: add haptic drvier on max77843 Documentation: Add device tree bindings document for max77843 Documentation/devicetree/bindings/mfd/max77843.txt | 110 +++++ drivers/input/misc/Kconfig | 12 + drivers/input/misc/Makefile | 1 + drivers/input/misc/max77843-haptic.c | 358 ++++++++++++++ drivers/mfd/Kconfig | 14 + drivers/mfd/Makefile | 1 + drivers/mfd/max77843.c | 243 ++++++++++ drivers/power/Kconfig | 16 + drivers/power/Makefile | 2 + drivers/power/max77843_battery.c | 286 +++++++++++ drivers/power/max77843_charger.c | 508 ++++++++++++++++++++ include/linux/mfd/max77843-private.h | 454 +++++++++++++++++ 12 files changed, 2005 insertions(+) create mode 100644 Documentation/devicetree/bindings/mfd/max77843.txt create mode 100644 drivers/input/misc/max77843-haptic.c create mode 100644 drivers/mfd/max77843.c create mode 100644 drivers/power/max77843_battery.c create mode 100644 drivers/power/max77843_charger.c create mode 100644 include/linux/mfd/max77843-private.h -- 1.7.9.5