From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753940AbbCJR2j (ORCPT ); Tue, 10 Mar 2015 13:28:39 -0400 Received: from mail-wi0-f181.google.com ([209.85.212.181]:46003 "EHLO mail-wi0-f181.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752616AbbCJR1q (ORCPT ); Tue, 10 Mar 2015 13:27:46 -0400 From: Bartosz Golaszewski To: LKML Cc: Guenter Roeck , lm-sensors , Andrew Morton , Steven Rostedt , Bartosz Golaszewski Subject: [PATCH v2 0/4] kernel.h: find_closest() macro Date: Tue, 10 Mar 2015 18:27:18 +0100 Message-Id: <1426008442-26236-1-git-send-email-bgolaszewski@baylibre.com> X-Mailer: git-send-email 2.1.4 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org This series proposes to unduplicate the code used to find the member in an array closest to 'x'. The first patch adds a macro implementing the algorithm in two flavors - for arrays sorted in ascending and descending order. Other three patches replace duplicated code with calls to one of these macros in some hwmon drivers. v2: - fixed an off-by-one bug in patch [3/4] v1: https://lkml.org/lkml/2015/2/24/509 Bartosz Golaszewski (4): kernel.h: add find_closest() macro hwmon: (ina2xx) replace ina226_avg_bits() with find_closest() hwmon: (lm85) replace x_TO_REG() functions with find_closest() hwmon: (w83795) use find_closest_desc() in pwm_freq_to_reg() drivers/hwmon/ina2xx.c | 16 ++-------------- drivers/hwmon/lm85.c | 43 ++++++++++++------------------------------- drivers/hwmon/w83795.c | 7 ++----- include/linux/kernel.h | 23 +++++++++++++++++++++++ 4 files changed, 39 insertions(+), 50 deletions(-) -- 2.1.4