From: Joe Perches <joe@perches.com>
To: Bartosz Golaszewski <bgolaszewski@baylibre.com>
Cc: LKML <linux-kernel@vger.kernel.org>,
Guenter Roeck <linux@roeck-us.net>,
lm-sensors <lm-sensors@lm-sensors.org>,
Andrew Morton <akpm@linux-foundation.org>,
Steven Rostedt <srostedt@redhat.com>
Subject: Re: [PATCH v2 1/4] kernel.h: add find_closest() macro
Date: Tue, 10 Mar 2015 11:27:12 -0700 [thread overview]
Message-ID: <1426012032.18060.18.camel@perches.com> (raw)
In-Reply-To: <1426008442-26236-2-git-send-email-bgolaszewski@baylibre.com>
On Tue, 2015-03-10 at 18:27 +0100, Bartosz Golaszewski wrote:
> Searching for the member of an array closest to 'x' is
> duplicated in several places.
[]
> diff --git a/include/linux/kernel.h b/include/linux/kernel.h
[]
> @@ -116,6 +116,29 @@
> } \
> )
>
> +#define __find_closest(x, a, as, op)( \
> +{ \
> + typeof(as) _i, _as = (as) - 1; \
> + typeof(x) _x = (x); \
> + typeof(*a) *_a = (a); \
> + for (_i = 0; _i < _as; _i++) { \
> + if (_x op DIV_ROUND_CLOSEST(_a[_i] + _a[_i + 1], 2)) \
> + break; \
> + } \
> + (_i); \
> +} \
> +)
Please use more descriptive variable names.
Most kernel statement expression macros consolidate
the "({" and "})" uses on single lines
#define sem(args) {( \
etc... \
)}
> +
> +/*
> + * Given an array 'a' (sorted in ascending order) of size 'as' return
> + * the index of the element in that array closest to 'x'.
> + */
It'd be nice to use kernel-doc comments here.
> +#define find_closest(x, a, as) __find_closest(x, a, as, <=)
> +/*
> + * Similar to find_closest(), but 'a' is expected to be sorted
> + * in descending order.
> + */
And here.
> +#define find_closest_desc(x, a, as) __find_closest(x, a, as, >)
Shouldn't find_closest and find_closest_dest use
equivalent comparison?
>= ?
next prev parent reply other threads:[~2015-03-10 18:27 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-03-10 17:27 [PATCH v2 0/4] kernel.h: " Bartosz Golaszewski
2015-03-10 17:27 ` [PATCH v2 1/4] kernel.h: add " Bartosz Golaszewski
2015-03-10 18:27 ` Joe Perches [this message]
2015-03-12 23:07 ` Andrew Morton
2015-03-10 17:27 ` [PATCH v2 2/4] hwmon: (ina2xx) replace ina226_avg_bits() with find_closest() Bartosz Golaszewski
2015-03-10 17:27 ` [PATCH v2 3/4] hwmon: (lm85) replace x_TO_REG() functions " Bartosz Golaszewski
2015-03-13 8:53 ` Rasmus Villemoes
2015-03-10 17:27 ` [PATCH v2 4/4] hwmon: (w83795) use find_closest_desc() in pwm_freq_to_reg() Bartosz Golaszewski
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1426012032.18060.18.camel@perches.com \
--to=joe@perches.com \
--cc=akpm@linux-foundation.org \
--cc=bgolaszewski@baylibre.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@roeck-us.net \
--cc=lm-sensors@lm-sensors.org \
--cc=srostedt@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome