From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752051AbbCKI0U (ORCPT ); Wed, 11 Mar 2015 04:26:20 -0400 Received: from szxga03-in.huawei.com ([119.145.14.66]:32860 "EHLO szxga03-in.huawei.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751704AbbCKI0L (ORCPT ); Wed, 11 Mar 2015 04:26:11 -0400 From: Wang Long To: , , , , CC: , , , , , , , Subject: [PATCH v2 0/5] Update the OF unittest and some small fix Date: Wed, 11 Mar 2015 08:36:49 +0000 Message-ID: <1426063014-211712-1-git-send-email-long.wanglong@huawei.com> X-Mailer: git-send-email 1.8.3.4 MIME-Version: 1.0 Content-Type: text/plain X-Originating-IP: [10.107.197.200] X-CFilter-Loop: Reflected X-Mirapoint-Virus-RAPID-Raw: score=unknown(0), refid=str=0001.0A020204.54FFFC11.0012,ss=1,re=0.001,recu=0.000,reip=0.000,cl=1,cld=1,fgs=0, ip=0.0.0.0, so=2013-05-26 15:14:31, dmn=2013-03-21 17:37:32 X-Mirapoint-Loop-Id: 1c9f6325ca7ae32c071da93dd5719d10 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org This series patches do some small fixes in drivers/of/unittest.c, and update the Documenttion. At last, replace selftest with unittest in the c, dtsi and binding files. * v2 <- v1: - According to Gaurav's advice. make the rename file patch correctly. Wang Long (5): of/unittest: remove the duplicate of_changeset_init of/unittest: Fix the wrong expected value in of_selftest_property_string Documentation: update the of_selftest.txt Documentation: rename of_selftest.txt to of_unittest.txt of/unittest: replace 'selftest' with 'unittest' Documentation/devicetree/bindings/unittest.txt | 44 +- .../{of_selftest.txt => of_unittest.txt} | 35 +- drivers/of/unittest-data/tests-overlay.dtsi | 108 ++-- drivers/of/unittest.c | 703 ++++++++++----------- 4 files changed, 445 insertions(+), 445 deletions(-) rename Documentation/devicetree/{of_selftest.txt => of_unittest.txt} (87%) -- 1.8.3.4