From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751755AbbCQDUs (ORCPT ); Mon, 16 Mar 2015 23:20:48 -0400 Received: from szxga02-in.huawei.com ([119.145.14.65]:58811 "EHLO szxga02-in.huawei.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751198AbbCQDUq (ORCPT ); Mon, 16 Mar 2015 23:20:46 -0400 From: Wang Long To: , , , CC: , , , , , , , Subject: [PATCH v3 0/3] replace 'selftest' with 'unittest' and update the document. Date: Tue, 17 Mar 2015 03:19:57 +0000 Message-ID: <1426562400-102415-1-git-send-email-long.wanglong@huawei.com> X-Mailer: git-send-email 1.8.3.4 MIME-Version: 1.0 Content-Type: text/plain X-Originating-IP: [10.107.197.200] X-CFilter-Loop: Reflected Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org This series patches replace 'selftest' with 'unittest' in the OF unittest, and update the document. the first patch comes from Gaurav Minocha, and i update it. because it can not apply on linux 4.0-rc4 when using 'git am' command. * v3 <- v2: - Rebase the patch on 4.0-rc4 - Re-adjust the sequence of the patches * v2 <- v1: - According to Gaurav's advice. make the rename file patch correctly. Wang Long (3): of/unittest: replace 'selftest' with 'unittest' Documentation: rename of_selftest.txt to of_unittest.txt Documentation: update the of_unittest.txt Documentation/devicetree/bindings/unittest.txt | 44 +- .../{of_selftest.txt => of_unittest.txt} | 35 +- drivers/of/unittest-data/tests-overlay.dtsi | 108 ++-- drivers/of/unittest.c | 706 ++++++++++----------- 4 files changed, 447 insertions(+), 446 deletions(-) rename Documentation/devicetree/{of_selftest.txt => of_unittest.txt} (87%) -- 1.8.3.4