From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751339AbbCSXyh (ORCPT ); Thu, 19 Mar 2015 19:54:37 -0400 Received: from ozlabs.org ([103.22.144.67]:41387 "EHLO ozlabs.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750734AbbCSXyg (ORCPT ); Thu, 19 Mar 2015 19:54:36 -0400 Message-ID: <1426809274.2581.0.camel@ellerman.id.au> Subject: Re: [23/32] powerpc: copy_thread(): rename 'arg' argument to 'kthread_arg' From: Michael Ellerman To: Alex Dowad Cc: linux-kernel@vger.kernel.org, Michael Neuling , Paul Gortmaker , Paul Mackerras , Anton Blanchard , Vineeth Vijayan , Christoph Lameter , "open list:LINUX FOR POWERPC..." Date: Fri, 20 Mar 2015 10:54:34 +1100 In-Reply-To: <550A794C.7020904@gmail.com> References: <20150319064519.6BEA814010F@ozlabs.org> <550A794C.7020904@gmail.com> Content-Type: text/plain; charset="UTF-8" X-Mailer: Evolution 3.12.10-0ubuntu1~14.10.1 Mime-Version: 1.0 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, 2015-03-19 at 09:22 +0200, Alex Dowad wrote: > On 19/03/15 08:45, Michael Ellerman wrote: > > On Fri, 2015-13-03 at 18:14:46 UTC, Alex Dowad wrote: > >> The 'arg' argument to copy_thread() is only ever used when forking a new > >> kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency > >> with do_fork() and other arch-specific implementations of copy_thread()). > > > > I don't understand the bit about consistency with do_fork() ? > This series of patches includes one patch which renames the arg for > do_fork(), and others which rename the same arg for each arch-specific > implementation of copy_thread(). So if all of them are accepted and > merged, then all will be consistent. If only some of the patches are > accepted, I will rewrite the commit message so it doesn't mention > "consistency". Ah OK, I only got patch 23, so I missed the context of the whole series. I'll apply this one to the powerpc tree. cheers