From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754199AbbCaDII (ORCPT ); Mon, 30 Mar 2015 23:08:08 -0400 Received: from smtprelay0176.hostedemail.com ([216.40.44.176]:58769 "EHLO smtprelay.hostedemail.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1754005AbbCaDIF (ORCPT ); Mon, 30 Mar 2015 23:08:05 -0400 X-Session-Marker: 6A6F6540706572636865732E636F6D X-Spam-Summary: 2,0,0,,d41d8cd98f00b204,joe@perches.com,:::::::::::::,RULES_HIT:41:355:379:541:599:982:988:989:1260:1277:1311:1313:1314:1345:1359:1373:1437:1515:1516:1518:1534:1539:1593:1594:1711:1714:1730:1747:1777:1792:2393:2559:2562:2828:2915:3138:3139:3140:3141:3142:3351:3622:3865:3867:3872:3873:4321:5007:6261:10004:10400:10848:11232:11658:11914:12043:12296:12517:12519:12740:13069:13311:13357:21080:21088,0,RBL:none,CacheIP:none,Bayesian:0.5,0.5,0.5,Netcheck:none,DomainCache:0,MSF:not bulk,SPF:fn,MSBL:0,DNSBL:none,Custom_rules:0:0:0 X-HE-Tag: geese27_2936d669fce4b X-Filterd-Recvd-Size: 1751 Message-ID: <1427771281.14276.48.camel@perches.com> Subject: Re: [PATCH v2 08/10] perf/hv24x7: Whitespace cleanup From: Joe Perches To: Sukadev Bhattiprolu Cc: Michael Ellerman , Paul Mackerras , peterz@infradead.org, dev@codyps.com, linux-kernel@vger.kernel.org, linuxppc-dev@lists.ozlabs.org Date: Mon, 30 Mar 2015 20:08:01 -0700 In-Reply-To: <1427766828-771-9-git-send-email-sukadev@linux.vnet.ibm.com> References: <1427766828-771-1-git-send-email-sukadev@linux.vnet.ibm.com> <1427766828-771-9-git-send-email-sukadev@linux.vnet.ibm.com> Content-Type: text/plain; charset="ISO-8859-1" X-Mailer: Evolution 3.12.10-0ubuntu1~14.10.1 Mime-Version: 1.0 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon, 2015-03-30 at 18:53 -0700, Sukadev Bhattiprolu wrote: > Fix minor whitespace damages. If you are going to do whitespace cleaning, please verify the patches with scripts/checkpatch.pl --strict. > diff --git a/arch/powerpc/perf/hv-24x7.c b/arch/powerpc/perf/hv-24x7.c [] > @@ -1077,7 +1079,6 @@ static unsigned long single_24x7_request(struct perf_event *event, u64 *count) > } > > resb = &result_buffer->results[0]; > - > *count = be64_to_cpu(resb->elements[0].element_data[0]); > out: > return ret; Does this deletion make the code easier to read? It might be better just to use: be64 val; ... val = result_buffer->results[0].elements[0].element_data[0]; *count = be64_to_cpu(val);