From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754646AbbCaNXo (ORCPT ); Tue, 31 Mar 2015 09:23:44 -0400 Received: from mailout2.samsung.com ([203.254.224.25]:33683 "EHLO mailout2.samsung.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754383AbbCaNXi (ORCPT ); Tue, 31 Mar 2015 09:23:38 -0400 X-AuditID: cbfee68e-f79b46d000002b74-39-551a9fd83039 From: Beomho Seo To: lee.jones@linaro.org, sre@kernel.org, robh+dt@kernel.org, pawel.moll@arm.com, mark.rutland@arm.com, ijc+devicetree@hellion.org.uk, galak@codeaurora.org Cc: linux-kernel@vger.kernel.org, linux-pm@vger.kernel.org, devicetree@vger.kernel.org, cw00.choi@samsung.com, sangbae90.lee@samsung.com, inki.dae@samsung.com, Beomho Seo Subject: [PATCH v8 0/2] Add new MFD driver for MAX77843 Date: Tue, 31 Mar 2015 22:23:33 +0900 Message-id: <1427808215-19178-1-git-send-email-beomho.seo@samsung.com> X-Mailer: git-send-email 1.7.9.5 X-Brightmail-Tracker: H4sIAAAAAAAAA+NgFnrHLMWRmVeSWpSXmKPExsWyRsSkQPfGfKlQgz1XZS1Of9rGbnH9y3NW i/lHzrFa9L9ZyGpx7tVKRotJ9yewWNz/epTR4vKuOWwWn3uPMFosvX6RyWLC9LUsFq17j7Bb HP90kMXi9O4SBz6PNfPWMHpc7utl8li5/Aubx6ZVnWwed67tYfPo27KK0ePzJrkA9igum5TU nMyy1CJ9uwSujBt9L5kK1ghW9PxdytrAOIu3i5GDQ0LAROLMUtUuRk4gU0ziwr31bF2MXBxC AksZJXbc2M0IUzOpmwkivohRYsvcXewQzg9GiUvvVrOBdLMJaEq8n3KFBSQhIjCfUaJz822w BLPAcUaJvY16ILawgLnE4sszWUBsFgFViT03f4LZvAJuEnuWd7NCbFOQmDPJBmSOhMAhdom5 fyAWsAgISHybfIgFokZWYtMBZoirJSUOrrjBMoFRcAEjwypG0dSC5ILipPQiI73ixNzi0rx0 veT83E2MwGg4/e9Z3w7GmwesDzEKcDAq8fBW3JEMFWJNLCuuzD3EaAq0YSKzlGhyPjDm8kri DY3NjCxMTUyNjcwtzZTEeROkfgYLCaQnlqRmp6YWpBbFF5XmpBYfYmTi4JRqYOz9dD4rW03i 3+RtJRcYZe35ftXJCj5OPXrn6MsPk8RMdb7NURDc6V5iEGfiv+bGhHD/Qx80+B3DtCY5b9/H M6Ocoaw72UpspcaKll31sUsSdq4p2zbX9fz0BQ/+1Bw221L+/tKufdfu+6U+FZIXY+ox0Xhd 9/nk+x2ryp8Ck1Wo7CWNyJN8rUosxRmJhlrMRcWJACQDfi6BAgAA X-Brightmail-Tracker: H4sIAAAAAAAAA+NgFtrJIsWRmVeSWpSXmKPExsVy+t9jAd0b86VCDTqmiFqc/rSN3eL6l+es FvOPnGO16H+zkNXi3KuVjBaT7k9gsbj/9SijxeVdc9gsPvceYbRYev0ik8WE6WtZLFr3HmG3 OP7pIIvF6d0lDnwea+atYfS43NfL5LFy+Rc2j02rOtk87lzbw+bRt2UVo8fnTXIB7FENjDYZ qYkpqUUKqXnJ+SmZeem2St7B8c7xpmYGhrqGlhbmSgp5ibmptkouPgG6bpk5QDcrKZQl5pQC hQISi4uV9O0wTQgNcdO1gGmM0PUNCYLrMTJAAwlrGDNu9L1kKlgjWNHzdylrA+Ms3i5GDg4J AROJSd1MXYycQKaYxIV769m6GLk4hAQWMUpsmbuLHcL5wShx6d1qNpAqNgFNifdTrrCAJEQE 5jNKdG6+DZZgFjjOKLG3UQ/EFhYwl1h8eSYLiM0ioCqx5+ZPMJtXwE1iz/JuVojNChJzJtlM YORewMiwilE0tSC5oDgpPddIrzgxt7g0L10vOT93EyM42p5J72Bc1WBxiFGAg1GJh7fijmSo EGtiWXFl7iFGCQ5mJRHenxOlQoV4UxIrq1KL8uOLSnNSiw8xmgItn8gsJZqcD0wEeSXxhsYm ZkaWRuaGFkbG5krivEr2bSFCAumJJanZqakFqUUwfUwcnFINjBW/0nUC5px0W/fTfs2yW0uS 1y3w8qm7einjOj9LYxlL6Ga1W1qbDaQuMCupLItJkGO4pfktKjTzvIftitdzf/GpvO7tf8Pg 8tVPLiel8Ym4bO5az+5g2ccT6nT01kUbFPtx3SngLP23Wsc4xE/cel2MlfGXiLBb5WG7p2WJ R3TxsOivUZ6mxFKckWioxVxUnAgAcLsU+cwCAAA= DLP-Filter: Pass X-MTR: 20000000000000000@CPGS X-CFilter-Loop: Reflected Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org This patch series adds MAX77843(Multi Function Device) driver. The MAX77843 includes MUIC(Micro USB Interface Controller), Li+ Charger with Fuel Gauge, 2 safeout LDOs for USB device and haptic controller using PWM. It is interfaced to host controller using I2C. Changes in v8: Charger: - Add "Reviewed-by: Sebastian Reichel" He reviewed this patch on Sun 8 Mar 2015. Fuelgauge: - Remove patch. Doc: - Remove about fuelgague. Changes in v7: MFD Core - Fix indentation - Remove file name, MODULE information POWER - Fix typos Changes in v6: HAPTIC - fixed a situation where holding a Mutex return. Changes in v5: MFD Core - Use bracket in complex define. - Delete unnecessary letter '++' Charger - fix Kconfig merge conflict with Kernel version4.0 Changes in v4: MFD Core - Fix indentation - Add haptic register define in header HAPTIC - Add haptic driver Changes in v3: MFD Core - Fix wrong description and indentation in header. - Remove unnecessary variable. Regulator - Use ARRAY_SIZE() instead of define. Changes in v2: MFD Core - Fix charger regmap handle and typo. MUIC - Cleanup enum list. - Set path before send excon event. - Fix variable names and typos for readability. Charger - Remove unnecessary header. - Chnage error message more readable. - Remove unnecessary lines. Fuelgauge - Fix regmap_config and use regmap_read. - Add i2c_unregister_device function on *_remove function. - Fix typo in Kconfig. Doc - Remove unnecessary lines. - Add example of charger regulator. Beomho Seo (1): power: max77843_charger: Add Max77843 charger device driver Jaewon Kim (1): Documentation: Add device tree bindings document for max77843 Documentation/devicetree/bindings/mfd/max77843.txt | 100 ++++ drivers/power/Kconfig | 7 + drivers/power/Makefile | 1 + drivers/power/max77843_charger.c | 508 ++++++++++++++++++++ 4 files changed, 616 insertions(+) create mode 100644 Documentation/devicetree/bindings/mfd/max77843.txt create mode 100644 drivers/power/max77843_charger.c -- 1.7.9.5