mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Tim Chen <tim.c.chen@linux.intel.com>
To: Jason Low <jason.low2@hp.com>
Cc: Morten Rasmussen <morten.rasmussen@arm.com>,
	Preeti U Murthy <preeti@linux.vnet.ibm.com>,
	"peterz@infradead.org" <peterz@infradead.org>,
	"mingo@kernel.org" <mingo@kernel.org>,
	Daniel Lezcano <daniel.lezcano@linaro.org>,
	"riel@redhat.com" <riel@redhat.com>,
	"vincent.guittot@linaro.org" <vincent.guittot@linaro.org>,
	"srikar@linux.vnet.ibm.com" <srikar@linux.vnet.ibm.com>,
	"pjt@google.com" <pjt@google.com>,
	"benh@kernel.crashing.org" <benh@kernel.crashing.org>,
	"efault@gmx.de" <efault@gmx.de>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"iamjoonsoo.kim@lge.com" <iamjoonsoo.kim@lge.com>,
	"svaidy@linux.vnet.ibm.com" <svaidy@linux.vnet.ibm.com>
Subject: Re: sched: Improve load balancing in the presence of idle CPUs
Date: Tue, 07 Apr 2015 12:39:24 -0700	[thread overview]
Message-ID: <1428435564.660.39.camel@schen9-desk2.jf.intel.com> (raw)
In-Reply-To: <1428428561.2556.63.camel@j-VirtualBox>

On Tue, 2015-04-07 at 10:42 -0700, Jason Low wrote:
> On Fri, 2015-04-03 at 15:35 -0700, Tim Chen wrote:
> > I think we can get rid of the done_balancing boolean 
> > and make it a bit easier to read if we change the above code to
> > 
> > diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
> > index bcfe320..08317dc 100644
> > --- a/kernel/sched/fair.c
> > +++ b/kernel/sched/fair.c
> > @@ -7557,8 +7557,13 @@ static void nohz_idle_balance(struct rq *this_rq, enum cpu_idle_type idle)
> >                  * work being done for other cpus. Next load
> >                  * balancing owner will pick it up.
> >                  */
> > -               if (need_resched())
> > -                       break;
> > +               if (need_resched()) {
> > +                       /* preparing to bail, kicking other cpu to continue */
> > +                       clear_bit(NOHZ_BALANCE_KICK, nohz_flags(this_cpu));
> > +                       if (nohz_kick_needed(this_rq))
> > +                               nohz_balance_kick();
> > +                       return;
> > +               }
> 
> Hi Tim,
> 
> We would also need the nohz_kick_needed/nohz_balance_kick if we
> initially find that the current CPU is not idle (at the beginning of
> nohz_idle_balance). In the above case, we would need to add the code to
> 2 locations.
> 
> Would it be better to still keep the done_balancing to avoid having
> duplicate code?
> 

How about consolidating the code for passing the
nohz balancing and call it at both places.  
Something like below.  Make the code more readable.

Tim

diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
index 40667cb..16f6904 100644
--- a/kernel/sched/fair.c
+++ b/kernel/sched/fair.c
@@ -7531,6 +7531,15 @@ out:
 }
 
 #ifdef CONFIG_NO_HZ_COMMON
+static inline int nohz_kick_needed(struct rq *rq);
+
+static void inline pass_nohz_balance(struct rq *this_rq, int this_cpu)
+{
+       clear_bit(NOHZ_BALANCE_KICK, nohz_flags(this_cpu));
+       if (nohz_kick_needed(this_rq))
+               nohz_balancer_kick();
+}
+
 /*
  * In CONFIG_NO_HZ_COMMON case, the idle balance kickee will do the
  * rebalancing for all the cpus for whom scheduler ticks are stopped.
@@ -7542,8 +7551,10 @@ static void nohz_idle_balance(struct rq *this_rq, enum cpu_idle_type idle)
        int balance_cpu;
 
        if (idle != CPU_IDLE ||
-           !test_bit(NOHZ_BALANCE_KICK, nohz_flags(this_cpu)))
-               goto end;
+           !test_bit(NOHZ_BALANCE_KICK, nohz_flags(this_cpu))) {
+               pass_nohz_balance(this_rq, this_cpu);
+               return;
+       }
 
        for_each_cpu(balance_cpu, nohz.idle_cpus_mask) {
                if (balance_cpu == this_cpu || !idle_cpu(balance_cpu))
@@ -7554,8 +7565,10 @@ static void nohz_idle_balance(struct rq *this_rq, enum cpu_idle_type idle)
                 * work being done for other cpus. Next load
                 * balancing owner will pick it up.
                 */
-               if (need_resched())
-                       break;
+               if (need_resched()) {
+                       pass_nohz_balance(this_rq, this_cpu);
+                       return;
+               }
 
                rq = cpu_rq(balance_cpu);
 
@@ -7575,7 +7588,6 @@ static void nohz_idle_balance(struct rq *this_rq, enum cpu_idle_type idle)
                        this_rq->next_balance = rq->next_balance;
        }
        nohz.next_balance = this_rq->next_balance;
-end:
        clear_bit(NOHZ_BALANCE_KICK, nohz_flags(this_cpu));
 }
 



  reply	other threads:[~2015-04-07 19:39 UTC|newest]

Thread overview: 30+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-03-30 18:55 Jason Low
2015-03-31  8:37 ` Preeti U Murthy
2015-03-31 18:54   ` Jason Low
2015-04-01  6:49     ` Preeti U Murthy
2015-04-01 17:04       ` Morten Rasmussen
2015-04-02  3:30         ` Jason Low
2015-04-02  8:49           ` Morten Rasmussen
2015-04-02  5:59         ` Jason Low
2015-04-02  8:42           ` Preeti U Murthy
2015-04-02  9:17           ` Morten Rasmussen
2015-04-02 17:22             ` Jason Low
2015-04-03 22:35           ` Tim Chen
2015-04-07 17:42             ` Jason Low
2015-04-07 19:39               ` Tim Chen [this message]
2015-04-07 20:24                 ` Jason Low
2015-04-04  9:59           ` Preeti U Murthy
2015-04-07 23:28             ` Jason Low
2015-04-08  0:07               ` Jason Low
2015-04-08 11:12                 ` Srikar Dronamraju
2015-04-08 21:22                   ` Jason Low
2015-04-10  8:37                     ` Srikar Dronamraju
2015-04-13 18:55                       ` Jason Low
2015-04-13 20:54                       ` Jason Low
2015-04-09  2:39                   ` Jason Low
2015-04-09  7:02                     ` Srikar Dronamraju
2015-04-09 22:49                       ` Jason Low
2015-04-13  6:16                 ` Preeti U Murthy
2015-04-13 22:49                   ` Jason Low
2015-04-14  2:59                     ` Jason Low
2015-04-02  2:11   ` Jason Low

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1428435564.660.39.camel@schen9-desk2.jf.intel.com \
    --to=tim.c.chen@linux.intel.com \
    --cc=benh@kernel.crashing.org \
    --cc=daniel.lezcano@linaro.org \
    --cc=efault@gmx.de \
    --cc=iamjoonsoo.kim@lge.com \
    --cc=jason.low2@hp.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@kernel.org \
    --cc=morten.rasmussen@arm.com \
    --cc=peterz@infradead.org \
    --cc=pjt@google.com \
    --cc=preeti@linux.vnet.ibm.com \
    --cc=riel@redhat.com \
    --cc=srikar@linux.vnet.ibm.com \
    --cc=svaidy@linux.vnet.ibm.com \
    --cc=vincent.guittot@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®