From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751406AbbDSEFW (ORCPT ); Sun, 19 Apr 2015 00:05:22 -0400 Received: from mail-pd0-f178.google.com ([209.85.192.178]:35957 "EHLO mail-pd0-f178.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751158AbbDSEFU (ORCPT ); Sun, 19 Apr 2015 00:05:20 -0400 From: Namhyung Kim To: Arnaldo Carvalho de Melo Cc: Ingo Molnar , Peter Zijlstra , Jiri Olsa , LKML , David Ahern Subject: [PATCHSET 0/7] perf tools: Assorted cleanup for TUI (v1) Date: Sun, 19 Apr 2015 13:04:08 +0900 Message-Id: <1429416255-12070-1-git-send-email-namhyung@kernel.org> X-Mailer: git-send-email 2.3.5 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hello, This patches are to cleanup TUI hists browser code for later work. I moved hist_entry_diff and hist_entry_tui under an union in order to reduce memory footprint of hist entry. Also split out hist browser functions to make it easier to read. It's available on 'perf/tui-cleanup-v1' branch in my tree: git://git.kernel.org/pub/scm/linux/kernel/git/namhyung/linux-perf.git Thanks, Namhyung Namhyung Kim (7): perf tools: Get rid of position field from struct hist_entry perf diff: Make hist_entry_diff fields union perf tools: Move TUI-specific fields to struct hist_entry_tui perf tools: Move init_have_children field to struct hist_entry_tui perf hists browser: Fix possible memory leak perf hists browser: Split popup menu actions perf hists browser: Simplify zooming code a bit tools/perf/ui/browsers/hists.c | 612 ++++++++++++++++++++++++++--------------- tools/perf/util/hist.c | 4 +- tools/perf/util/pstack.c | 7 + tools/perf/util/pstack.h | 1 + tools/perf/util/sort.h | 31 ++- 5 files changed, 411 insertions(+), 244 deletions(-) -- 2.3.5