From: Paolo Bonzini <pbonzini@redhat.com>
To: Vitaly Kuznetsov <vkuznets@redhat.com>,
Sean Christopherson <seanjc@google.com>
Cc: Tom Rix <trix@redhat.com>,
kvm@vger.kernel.org, llvm@lists.linux.dev,
linux-kernel@vger.kernel.org,
Nathan Chancellor <nathan@kernel.org>,
Nick Desaulniers <ndesaulniers@google.com>
Subject: Re: [PATCH 2/2] KVM: VMX: Stub out enable_evmcs static key for CONFIG_HYPERV=n
Date: Thu, 9 Feb 2023 14:56:30 +0100 [thread overview]
Message-ID: <1433ea0c-5072-b9d9-a533-401bb58f9a80@redhat.com> (raw)
In-Reply-To: <87mt5n6kx6.fsf@redhat.com>
On 2/9/23 14:13, Vitaly Kuznetsov wrote:
>> +static __always_inline bool is_evmcs_enabled(void)
>> +{
>> + return static_branch_unlikely(&enable_evmcs);
>> +}
> I have a suggestion. While 'is_evmcs_enabled' name is certainly not
> worse than 'enable_evmcs', it may still be confusing as it's not clear
> which eVMCS is meant: are we running a guest using eVMCS or using eVMCS
> ourselves? So what if we rename this to a very explicit 'is_kvm_on_hyperv()'
> and hide the implementation details (i.e. 'evmcs') inside?
I prefer keeping eVMCS in the name, but I agree a better name could be
something like kvm_uses_evmcs()?
Paolo
next prev parent reply other threads:[~2023-02-09 13:57 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-02-08 20:54 [PATCH 0/2] KVM: VMX: Stub out enable_evmcs static key Sean Christopherson
2023-02-08 20:54 ` [PATCH 1/2] KVM: nVMX: Move EVMCS1_SUPPORT_* macros to hyperv.c Sean Christopherson
2023-02-09 13:08 ` Vitaly Kuznetsov
2023-02-08 20:54 ` [PATCH 2/2] KVM: VMX: Stub out enable_evmcs static key for CONFIG_HYPERV=n Sean Christopherson
2023-02-09 13:13 ` Vitaly Kuznetsov
2023-02-09 13:56 ` Paolo Bonzini [this message]
2023-02-10 1:13 ` Sean Christopherson
2023-02-10 9:55 ` Vitaly Kuznetsov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1433ea0c-5072-b9d9-a533-401bb58f9a80@redhat.com \
--to=pbonzini@redhat.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=llvm@lists.linux.dev \
--cc=nathan@kernel.org \
--cc=ndesaulniers@google.com \
--cc=seanjc@google.com \
--cc=trix@redhat.com \
--cc=vkuznets@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®