From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S933271AbbGHKOU (ORCPT ); Wed, 8 Jul 2015 06:14:20 -0400 Received: from mx0b-0016f401.pphosted.com ([67.231.156.173]:50503 "EHLO mx0b-0016f401.pphosted.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1758118AbbGHKOR (ORCPT ); Wed, 8 Jul 2015 06:14:17 -0400 From: Jisheng Zhang To: , , , , , CC: , , Jisheng Zhang Subject: [PATCH 0/4] arm: psci: implement cpuidle_ops Date: Wed, 8 Jul 2015 18:13:33 +0800 Message-ID: <1436350417-6712-1-git-send-email-jszhang@marvell.com> X-Mailer: git-send-email 2.1.4 MIME-Version: 1.0 Content-Type: text/plain X-Proofpoint-Virus-Version: vendor=fsecure engine=2.50.10432:,, definitions=2015-07-08_05:,, signatures=0 X-Proofpoint-Spam-Details: rule=outbound_notspam policy=outbound score=0 kscore.is_bulkscore=0 kscore.compositescore=1 compositescore=0.9 suspectscore=0 malwarescore=0 phishscore=0 bulkscore=0 kscore.is_spamscore=0 rbsscore=0.9 spamscore=0 urlsuspectscore=0.9 adultscore=0 classifier=spam adjust=0 reason=mlx scancount=1 engine=8.0.1-1506180000 definitions=main-1507080168 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org We'd like to use cpuidle-arm.c for both arm and arm64 with psci as backend. For arm64, it works. But for arm, we miss cpuidle_ops, these patches try to address this issue. Has been tested on Marvell Berlin SoCs. These patches are rebased on the Mark Rutland's latest psci unification work and Lorenzo Pieralisi's psci related work[1]. [PATCH 1/4] renames psci_smp.c to psci.c to prepare for the next two changes. [PATCH 2/4] enables PSCI on UP systems [PATCH 3/4] move psci's cpu_suspend handling to generic code as suggested by Lorenzo. [PATCH 4/4] implement cpuidle_ops with psci finally. [1] http://lists.infradead.org/pipermail/linux-arm-kernel/2015-May/347352.html Jisheng Zhang (4): arm: psci: rename psci_smp.c to psci.c arm: psci: enable PSCI on UP systems firmware: psci: move cpu_suspend handling to generic code arm: psci: add cpuidle_ops support arch/arm/kernel/Makefile | 5 +- arch/arm/kernel/{psci_smp.c => psci.c} | 22 ++++++++ arch/arm64/kernel/psci.c | 95 ---------------------------------- drivers/firmware/psci.c | 95 ++++++++++++++++++++++++++++++++++ include/linux/psci.h | 2 + 5 files changed, 120 insertions(+), 99 deletions(-) rename arch/arm/kernel/{psci_smp.c => psci.c} (86%) -- 2.1.4