From: Sudip Mukherjee <sudipm.mukherjee@gmail.com>
To: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: linux-kernel@vger.kernel.org, devel@driverdev.osuosl.org,
Sudip Mukherjee <sudipm.mukherjee@gmail.com>
Subject: [PATCH 3/6] staging: rtl8188eu: remove goto label
Date: Thu, 16 Jul 2015 16:58:09 +0530 [thread overview]
Message-ID: <1437046092-16363-3-git-send-email-sudipm.mukherjee@gmail.com> (raw)
In-Reply-To: <1437046092-16363-1-git-send-email-sudipm.mukherjee@gmail.com>
By checking for the success of kzalloc we were able to remove the goto
label thus making the code more readable.
Signed-off-by: Sudip Mukherjee <sudip@vectorindia.org>
---
drivers/staging/rtl8188eu/os_dep/usb_intf.c | 11 ++++-------
1 file changed, 4 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/rtl8188eu/os_dep/usb_intf.c b/drivers/staging/rtl8188eu/os_dep/usb_intf.c
index 21744a5..f68875b 100644
--- a/drivers/staging/rtl8188eu/os_dep/usb_intf.c
+++ b/drivers/staging/rtl8188eu/os_dep/usb_intf.c
@@ -115,14 +115,11 @@ static struct dvobj_priv *usb_dvobj_init(struct usb_interface *usb_intf)
mutex_init(&pdvobjpriv->usb_vendor_req_mutex);
pdvobjpriv->usb_vendor_req_buf = kzalloc(MAX_USB_IO_CTL_SIZE, GFP_KERNEL);
- if (!pdvobjpriv->usb_vendor_req_buf)
- goto free_dvobj;
-
- usb_get_dev(pusbd);
-
- status = _SUCCESS;
+ if (pdvobjpriv->usb_vendor_req_buf) {
+ usb_get_dev(pusbd);
+ status = _SUCCESS;
+ }
-free_dvobj:
if (status != _SUCCESS) {
usb_set_intfdata(usb_intf, NULL);
kfree(pdvobjpriv);
--
1.8.1.2
next prev parent reply other threads:[~2015-07-16 11:28 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-07-16 11:28 [PATCH 1/6] staging: rtl8188eu: remove unused function Sudip Mukherjee
2015-07-16 11:28 ` [PATCH 2/6] staging: rtl8188eu: remove redundant NULL check Sudip Mukherjee
2015-07-16 11:28 ` Sudip Mukherjee [this message]
2015-07-17 11:03 ` [PATCH 3/6] staging: rtl8188eu: remove goto label Dan Carpenter
2015-07-17 11:25 ` Sudip Mukherjee
2015-07-17 11:47 ` Dan Carpenter
2015-07-17 12:03 ` Sudip Mukherjee
2015-07-16 11:28 ` [PATCH 4/6] staging: rtl8188eu: remove unneeded variable Sudip Mukherjee
2015-07-16 11:28 ` [PATCH 5/6] staging: rtl8188eu: stop using DBG_88E Sudip Mukherjee
2015-07-17 15:33 ` Jakub Sitnicki
2015-07-18 4:46 ` Sudip Mukherjee
2015-07-18 18:03 ` Jakub Sitnicki
2015-07-20 5:29 ` Sudip Mukherjee
2015-07-16 11:28 ` [PATCH 6/6] staging: rtl8188eu: remove unneeded ret Sudip Mukherjee
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1437046092-16363-3-git-send-email-sudipm.mukherjee@gmail.com \
--to=sudipm.mukherjee@gmail.com \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®