From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752770AbbHSG4y (ORCPT ); Wed, 19 Aug 2015 02:56:54 -0400 Received: from bhuna.collabora.co.uk ([93.93.135.160]:36422 "EHLO bhuna.collabora.co.uk" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751896AbbHSG4w convert rfc822-to-8bit (ORCPT ); Wed, 19 Aug 2015 02:56:52 -0400 Message-ID: <1439967408.4135.84.camel@collabora.co.uk> Subject: Re: [PATCH v3 2/4] ASoC: rockchip: Add rockchip SPDIF transceiver driver From: Sjoerd Simons To: Heiko Stuebner Cc: linux-rockchip@lists.infradead.org, Jaroslav Kysela , devicetree@vger.kernel.org, alsa-devel@alsa-project.org, Mark Brown , linux-kernel@vger.kernel.org, Kumar Gala , Ian Campbell , Takashi Iwai , Liam Girdwood , Pawel Moll , Rob Herring , Mark Rutland , Russell King , linux-arm-kernel@lists.infradead.org Date: Wed, 19 Aug 2015 08:56:48 +0200 In-Reply-To: <1463451.tH10lfH9Hm@phil> References: <1438947854-3743-1-git-send-email-sjoerd.simons@collabora.co.uk> <1438947854-3743-3-git-send-email-sjoerd.simons@collabora.co.uk> <1463451.tH10lfH9Hm@phil> Organization: Collabora Ltd. Content-Type: text/plain; charset="UTF-8" Content-Transfer-Encoding: 8BIT X-Mailer: Evolution 3.16.3-1 Mime-Version: 1.0 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hey Heiko, Thanks for the comments, i'm hoping to address them and Marks comments in a next patch series next week. On Tue, 2015-08-18 at 20:25 +0200, Heiko Stuebner wrote: > > + > > + spdif->hclk = devm_clk_get(&pdev->dev, "spdif_hclk"); > I guess this could be named just "hclk" - as it is the identifier > local to the spdif-ip. (Of course in the binding too) I'm entirely happy to change that, just wanted to note that the reason i used spdif_hclk and spidf_clk is for consistency with the rockchip -i2s binding which uses i2s_hclk ans i2s_mclk. However i guess we could update the i2s binding at some poit as well to follow similar names (with fallbacks to the old one). In general a lot of the comments yourself and Mark have given actually apply to the rockchip-i2s code as well so there is some cleanup to do there :) -- Sjoerd Simons Collabora Ltd.