From: Chenhui Zhao <chenhui.zhao@freescale.com>
To: Scott Wood <scottwood@freescale.com>
Cc: <linuxppc-dev@lists.ozlabs.org>, <linux-kernel@vger.kernel.org>,
<Jason.Jin@freescale.com>
Subject: Re: [PATCH v2,4/5] PowerPC/mpc85xx: Add hotplug support on E5500 and E500MC cores
Date: Fri, 28 Aug 2015 08:47:27 +0800 [thread overview]
Message-ID: <1440722847.31670.1@remotesmtp.freescale.net> (raw)
In-Reply-To: <20150826205554.GB10582@home.buserror.net>
On Thu, Aug 27, 2015 at 4:55 AM, Scott Wood <scottwood@freescale.com>
wrote:
> On Wed, Aug 26, 2015 at 08:09:47PM +0800, Chenhui Zhao wrote:
>> +int check_cpu_dead(unsigned int cpu)
>> +{
>> + return per_cpu(cpu_state, cpu) == CPU_DEAD;
>> +}
>
> I'm not sure this needs to be a function versus open-coded, but if
> you do
> want to make it a function, make it more obvious from the caller side
> by
> changing it to:
>
> bool is_cpu_dead(unsigned int cpu);
>
> Otherwise if I see "if (check_cpu_dead(cpu))" I don't know if the
> if-block is executed if the CPU is dead or if it isn't.
OK.
>
>
>> diff --git a/arch/powerpc/platforms/85xx/smp.h
>> b/arch/powerpc/platforms/85xx/smp.h
>> index 0b20ae3..8ee19a3 100644
>> --- a/arch/powerpc/platforms/85xx/smp.h
>> +++ b/arch/powerpc/platforms/85xx/smp.h
>> @@ -6,6 +6,7 @@
>> #ifdef CONFIG_SMP
>> void __init mpc85xx_smp_init(void);
>> int __init mpc85xx_setup_pmc(void);
>> +int __init fsl_rcpm_init(void);
>> #else
>
> Why wasn't this added in the patch that added fsl_rcpm_init()?
>
> -Scott
Will move it to there.
Thanks,
-Chenhui
next prev parent reply other threads:[~2015-08-28 1:02 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-08-26 12:09 [PATCH v2,1/5] powerpc/cache: add cache flush operation for various e500 Chenhui Zhao
2015-08-26 12:09 ` [PATCH v2,2/5] powerpc/rcpm: add RCPM driver Chenhui Zhao
2015-08-26 20:35 ` Scott Wood
2015-08-28 0:40 ` Scott Wood
2015-08-28 5:18 ` Scott Wood
2015-08-26 12:09 ` [PATCH v2,3/5] Powerpc: mpc85xx: refactor the PM operations Chenhui Zhao
2015-08-26 12:09 ` [PATCH v2,4/5] PowerPC/mpc85xx: Add hotplug support on E5500 and E500MC cores Chenhui Zhao
2015-08-26 20:55 ` Scott Wood
2015-08-28 0:47 ` Chenhui Zhao [this message]
2015-08-26 12:09 ` [PATCH v2,5/5] PowerPC/mpc85xx: Add CPU hotplug support for E6500 Chenhui Zhao
2015-08-26 22:42 ` Scott Wood
2015-08-28 1:42 ` Chenhui Zhao
2015-08-28 5:13 ` Scott Wood
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1440722847.31670.1@remotesmtp.freescale.net \
--to=chenhui.zhao@freescale.com \
--cc=Jason.Jin@freescale.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linuxppc-dev@lists.ozlabs.org \
--cc=scottwood@freescale.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®