From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751688AbbIOTwr (ORCPT ); Tue, 15 Sep 2015 15:52:47 -0400 Received: from mail-wi0-f171.google.com ([209.85.212.171]:38152 "EHLO mail-wi0-f171.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750750AbbIOTwq (ORCPT ); Tue, 15 Sep 2015 15:52:46 -0400 From: Eric Curtin To: ericcurtin17@gmail.com Cc: linux-kernel@vger.kernel.org Subject: First kernel patch (optimization) Date: Tue, 15 Sep 2015 20:52:39 +0100 Message-Id: <1442346759-3740-1-git-send-email-ericcurtin17@gmail.com> X-Mailer: git-send-email 2.4.3 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org My first kernel patch, hope I did everything correctly! Instead of calling strlen on every iteration of the for loop, just call it once instead and store in a variable. Signed-off-by: Eric Curtin diff --git a/tools/usb/usbip/src/usbip_detach.c b/tools/usb/usbip/src/usbip_detach.c index 05c6d15..9db9d21 100644 --- a/tools/usb/usbip/src/usbip_detach.c +++ b/tools/usb/usbip/src/usbip_detach.c @@ -47,7 +47,9 @@ static int detach_port(char *port) uint8_t portnum; char path[PATH_MAX+1]; - for (unsigned int i = 0; i < strlen(port); i++) + unsigned int port_len = strlen(port); + + for (unsigned int i = 0; i < port_len; i++) if (!isdigit(port[i])) { err("invalid port %s", port); return -1;