From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753089AbbIRM5b (ORCPT ); Fri, 18 Sep 2015 08:57:31 -0400 Received: from mail-wi0-f178.google.com ([209.85.212.178]:37098 "EHLO mail-wi0-f178.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751418AbbIRM53 (ORCPT ); Fri, 18 Sep 2015 08:57:29 -0400 From: LABBE Corentin To: herbert@gondor.apana.org.au, davem@davemloft.net Cc: linux-kernel@vger.kernel.org, linux-crypto@vger.kernel.org Subject: [PATCH v2] crypto: Remove duplicate code of SG helpers functions Date: Fri, 18 Sep 2015 14:57:08 +0200 Message-Id: <1442581036-23789-1-git-send-email-clabbe.montjoie@gmail.com> X-Mailer: git-send-email 2.4.6 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hello This patch series try to remove some duplicate code of some SG helpers functions. The first four patch replace custom functions by already in-tree helper functions. The fourth add a new functions "sg_nents_len_chained" who is the same as sg_nents_for_len with an additionnal arguments. The last three patch use sg_nents_len_chained for removing custom functions. Note that I do not own any of those hardware to test. Regards