From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S933556AbbIVNpa (ORCPT ); Tue, 22 Sep 2015 09:45:30 -0400 Received: from m12-14.163.com ([220.181.12.14]:46220 "EHLO m12-14.163.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S933337AbbIVNp3 (ORCPT ); Tue, 22 Sep 2015 09:45:29 -0400 From: Yaowei Bai To: rostedt@goodmis.org, mingo@redhat.com Cc: linux-kernel@vger.kernel.org Subject: [PATCH 2/2] kernel/trace_probe: is_good_name can be boolean Date: Tue, 22 Sep 2015 21:43:13 +0800 Message-Id: <1442929393-4753-2-git-send-email-bywxiaobai@163.com> X-Mailer: git-send-email 1.9.1 In-Reply-To: <1442929393-4753-1-git-send-email-bywxiaobai@163.com> References: <1442929393-4753-1-git-send-email-bywxiaobai@163.com> X-CM-TRANSID: DsCowECZaEloWwFWGR2cCg--.43666S4 X-Coremail-Antispam: 1Uf129KBjvdXoWrtF1DZw17CF45Cw13AF4xJFb_yoWDWwc_Aw 1UGwn7Jr4jkrs7ur4xAa97ZrW3Gay8Zryjvw1kt3y5Zw15urn8Ca4rCr9xtrWUWr4v9F98 Cr13WrZ2kFWfKjkaLaAFLSUrUUUUUb8apTn2vfkv8UJUUUU8Yxn0WfASr-VFAUDa7-sFnT 9fnUUvcSsGvfC2KfnxnUUI43ZEXa7IU5xfH5UUUUU== X-Originating-IP: [58.208.66.254] X-CM-SenderInfo: xe1z5x5dretxi6rwjhhfrp/1tbisAt9T1UL3RJ9mQAAs8 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org This patch makes is_good_name return bool to improve readability due to this particular function only using either one or zero as its return value. No functional change. Signed-off-by: Yaowei Bai --- kernel/trace/trace_probe.h | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/kernel/trace/trace_probe.h b/kernel/trace/trace_probe.h index b98dee9..f6398db 100644 --- a/kernel/trace/trace_probe.h +++ b/kernel/trace/trace_probe.h @@ -302,15 +302,15 @@ static nokprobe_inline void call_fetch(struct fetch_param *fprm, } /* Check the name is good for event/group/fields */ -static inline int is_good_name(const char *name) +static inline bool is_good_name(const char *name) { if (!isalpha(*name) && *name != '_') - return 0; + return false; while (*++name != '\0') { if (!isalpha(*name) && !isdigit(*name) && *name != '_') - return 0; + return false; } - return 1; + return true; } static inline struct event_file_link * -- 1.9.1