From: ahaslam@baylibre.com
To: khilman@linaro.org, ulf.hansson@linaro.org, lina.iyer@linaro.org,
geert@glider.be, k.kozlowski.k@gmail.com, rjw@rjwysocki.net,
linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org
Cc: bcousson@baylibre.com, mturquette@baylibre.com,
Axel Haslam <ahaslam+renesas@baylibre.com>
Subject: [PATCH v10 0/6] Multiple intermediate states for genpd
Date: Tue, 20 Oct 2015 15:26:23 +0200 [thread overview]
Message-ID: <1445347589-5626-1-git-send-email-ahaslam@baylibre.com> (raw)
From: Axel Haslam <ahaslam+renesas@baylibre.com>
Some architectures may have intermediate power levels between on and off.
This patch set adds the ability to declare multiple states for a given
generic power domain, the idea is that the deepest state will be entered
which does not violate any of the device or sub-domain latency constraints.
Changes since v9
*rebased on linux-next
Changes since v8
* rebased to linux-pm next
Changes since v7:
* rebase to 4.3-rc5
* add genpd_init_simple (Lina's suggestion) for platforms that don't have
multiple states and don't declare initial latencies. A default OFF
state with initial 0 latencies will be used in this case.
* Append Mark's patch to add "states" and "timings" to the genpd
debugfs
Changes since v6:
* change int to unsigned int were appropriate.
* spelling mistakes, and fix commit message for removal of latencies.
Changes since v5:
* rebase to 4.1-rc1
* Pass state array as an init argument on pm_genpd_init
* declare a default OFF state with no latencies, that will be used if a
null state argument is given.
* set the deepest state when using sync_poweroff.
* create and use name allocation function in the debug area
instead of inline.
Changes since v4:
* move to power_on/off callbacks out of the state array Platforms can
check the state_idx to know what state the power on/off corresponds to.
* convert states to pointer,
Dynamically allocate the states array to save memory on platforms
with several power domains.
* rename target_state to state_idx and remove init_state.
Changes since v3:
* remove old power on/off function at the end of the
series so that compilation will not break in between.
Changes since v2:
* remove state argument and macros from save/restore callbacks.
* added init_state for platforms to pass the initial state when the genpd
is initially off.
* convert current genpd users for the structure changes.
Changes since v1:
* split the changes so that the actual logic that selects the target state
is a separate patch.
* move the cached logic out of the state function and add
it back to default_power_down_ok.
* rename default_power_down_ok_state to power_down_ok_for_state
Axel Haslam (5):
PM / Domains: prepare for multiple states
PM / Domains: core changes for multiple states
PM / Domains: make governor select deepest state
ARM: imx6: pm: declare pm domain latency on power_state struct.
PM / Domains: remove old power on/off latencies.
Marc Titinger (1):
PM / Domains: add debugfs 'states' and 'timings' seq files
arch/arm/mach-exynos/pm_domains.c | 2 +-
arch/arm/mach-imx/gpc.c | 18 ++-
arch/arm/mach-s3c64xx/pm.c | 4 +-
arch/arm/mach-shmobile/pm-rmobile.c | 2 +-
arch/arm/mach-ux500/pm_domains.c | 2 +-
arch/arm/mach-zx/zx296702-pm-domain.c | 2 +-
drivers/base/power/domain.c | 258 ++++++++++++++++++++++++++++++++--
drivers/base/power/domain_governor.c | 70 +++++----
drivers/clk/qcom/gdsc.c | 2 +-
drivers/clk/shmobile/clk-mstp.c | 2 +-
drivers/soc/dove/pmu.c | 2 +-
drivers/soc/mediatek/mtk-scpsys.c | 2 +-
drivers/soc/rockchip/pm_domains.c | 2 +-
include/linux/pm_domain.h | 33 ++++-
14 files changed, 346 insertions(+), 55 deletions(-)
--
2.4.5
next reply other threads:[~2015-10-20 13:26 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-10-20 13:26 ahaslam [this message]
2015-10-20 13:26 ` [PATCH v10 1/6] PM / Domains: prepare for multiple states ahaslam
2015-10-27 14:33 ` Ulf Hansson
2015-10-27 17:04 ` Axel Haslam
2015-10-20 13:26 ` [PATCH v10 2/6] PM / Domains: core changes " ahaslam
[not found] ` <CAN2waFuQ+72zstgdD7GbxOr=d1T1wkqRvRePfL8KJbTceEGdzA@mail.gmail.com>
2015-11-10 11:02 ` Axel Haslam
2015-10-20 13:26 ` [PATCH v10 3/6] PM / Domains: make governor select deepest state ahaslam
2015-11-10 9:42 ` Zhaoyang Huang
2015-11-10 13:58 ` Axel Haslam
2015-10-20 13:26 ` [PATCH v10 4/6] ARM: imx6: pm: declare pm domain latency on power_state struct ahaslam
2015-10-20 13:26 ` [PATCH v10 5/6] PM / Domains: remove old power on/off latencies ahaslam
2015-10-20 13:26 ` [PATCH v10 6/6] PM / Domains: add debugfs 'states' and 'timings' seq files ahaslam
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1445347589-5626-1-git-send-email-ahaslam@baylibre.com \
--to=ahaslam@baylibre.com \
--cc=ahaslam+renesas@baylibre.com \
--cc=bcousson@baylibre.com \
--cc=geert@glider.be \
--cc=k.kozlowski.k@gmail.com \
--cc=khilman@linaro.org \
--cc=lina.iyer@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=mturquette@baylibre.com \
--cc=rjw@rjwysocki.net \
--cc=ulf.hansson@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®