From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1030421AbbKEXna (ORCPT ); Thu, 5 Nov 2015 18:43:30 -0500 Received: from us-mx2.synaptics.com ([192.147.44.131]:47452 "EHLO us-mx1.synaptics.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1030324AbbKEXn1 (ORCPT ); Thu, 5 Nov 2015 18:43:27 -0500 X-PGP-Universal: processed; by securemail.synaptics.com on Thu, 05 Nov 2015 16:43:50 -0800 From: Andrew Duggan To: , CC: Andrew Duggan , Dmitry Torokhov , Linus Walleij , Benjamin Tissoires , Christopher Heiny , Stephen Chandler Paul Subject: [PATCH 26/26] Input: synaptics-rmi4: Change the rmi device's name to be less generic Date: Thu, 5 Nov 2015 15:43:20 -0800 Message-ID: <1446767000-31398-1-git-send-email-aduggan@synaptics.com> X-Mailer: git-send-email 2.1.4 MIME-Version: 1.0 Content-Type: text/plain X-Originating-IP: [10.4.10.145] Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Currently, the rmi device has the name sensorXX. Sensor is very generic and in cases when there is little context it is hard to tell what the device is (ie in /sys/devices or /proc/interrupts). This patch changes the name to rmiXX which at least indicates that it is an rmi device. Signed-off-by: Andrew Duggan --- Linus Walleij suggested that we use the TM number as the device name. But, we need to set the device name when we add the device before we read the TM number. Changing the name to rmiXX is a compromise since it's not as unique as the TM, but not as generic as sensor. drivers/input/rmi4/rmi_bus.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/input/rmi4/rmi_bus.c b/drivers/input/rmi4/rmi_bus.c index a04468d..998b4e1 100644 --- a/drivers/input/rmi4/rmi_bus.c +++ b/drivers/input/rmi4/rmi_bus.c @@ -66,7 +66,7 @@ int rmi_register_transport_device(struct rmi_transport_dev *xport) rmi_dev->xport = xport; rmi_dev->number = atomic_inc_return(&transport_device_count) - 1; - dev_set_name(&rmi_dev->dev, "sensor%02d", rmi_dev->number); + dev_set_name(&rmi_dev->dev, "rmi%02d", rmi_dev->number); rmi_dev->dev.bus = &rmi_bus_type; rmi_dev->dev.type = &rmi_device_type; -- 2.1.4