From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752690AbbKPNW3 (ORCPT ); Mon, 16 Nov 2015 08:22:29 -0500 Received: from mail-wm0-f47.google.com ([74.125.82.47]:33765 "EHLO mail-wm0-f47.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752088AbbKPNW0 (ORCPT ); Mon, 16 Nov 2015 08:22:26 -0500 From: mhocko@kernel.org To: Andrew Morton Cc: Mel Gorman , David Rientjes , , LKML Subject: [PATCH 0/2] get rid of __alloc_pages_high_priority Date: Mon, 16 Nov 2015 14:22:17 +0100 Message-Id: <1447680139-16484-1-git-send-email-mhocko@kernel.org> X-Mailer: git-send-email 2.6.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi, this has been posted http://lkml.kernel.org/r/1447343618-19696-1-git-send-email-mhocko%40kernel.org last week. David has requested to split the patch into two parts one to removed and opencode __alloc_pages_high_priority without any functional changes and the other one which changes the retry behavior for __GFP_NOFAIL with ALLOC_NO_WATERMARKS allocation context. This was reflected in this submission. The end result is very same so I've kept Mel's Acked-by. Let me know if you do not agree with this Mel and I will drop it. mm/page_alloc.c | 48 +++++++++++++++++------------------------------- 1 file changed, 17 insertions(+), 31 deletions(-)