From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754772AbcAMGui (ORCPT ); Wed, 13 Jan 2016 01:50:38 -0500 Received: from szxga02-in.huawei.com ([119.145.14.65]:40412 "EHLO szxga02-in.huawei.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750967AbcAMGuf (ORCPT ); Wed, 13 Jan 2016 01:50:35 -0500 From: Kejian Yan To: , , , , , , , , , , , , , , , , , , CC: , , , , , Subject: [patch v3 net-next 2/2] net: hns: fixes no syscon error when init mdio Date: Wed, 13 Jan 2016 15:09:59 +0800 Message-ID: <1452668999-443-3-git-send-email-yankejian@huawei.com> X-Mailer: git-send-email 2.4.1 In-Reply-To: <1452668999-443-1-git-send-email-yankejian@huawei.com> References: <1452668999-443-1-git-send-email-yankejian@huawei.com> MIME-Version: 1.0 Content-Type: text/plain X-Originating-IP: [10.71.200.59] X-CFilter-Loop: Reflected X-Mirapoint-Virus-RAPID-Raw: score=unknown(0), refid=str=0001.0A020202.5695F3AF.0092,ss=1,re=0.000,recu=0.000,reip=0.000,cl=1,cld=1,fgs=512, ip=0.0.0.0, so=2013-06-18 04:22:30, dmn=2013-03-21 17:37:32 X-Mirapoint-Loop-Id: 98c63039aa0dcee707d47ec9b980d974 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org As dtsi files use the normal naming conventions using '-' instead of '_' inside of property names, the driver needs to update the phandle name strings of the of_parse_phandle func. Signed-off-by: Kejian Yan --- change log: v3: same as v2 v2: adds the initial version, because using '-' instead of '_' v1: does not exist. v2 patch link: https://lkml.org/lkml/2015/12/7/77 --- drivers/net/ethernet/hisilicon/hns_mdio.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/net/ethernet/hisilicon/hns_mdio.c b/drivers/net/ethernet/hisilicon/hns_mdio.c index 37491c8..1e07e91 100644 --- a/drivers/net/ethernet/hisilicon/hns_mdio.c +++ b/drivers/net/ethernet/hisilicon/hns_mdio.c @@ -458,7 +458,7 @@ static int hns_mdio_probe(struct platform_device *pdev) } mdio_dev->subctrl_vbase = - syscon_node_to_regmap(of_parse_phandle(np, "subctrl_vbase", 0)); + syscon_node_to_regmap(of_parse_phandle(np, "subctrl-vbase", 0)); if (IS_ERR(mdio_dev->subctrl_vbase)) { dev_warn(&pdev->dev, "no syscon hisilicon,peri-c-subctrl\n"); mdio_dev->subctrl_vbase = NULL; -- 2.4.1