From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755916AbcBCNZw (ORCPT ); Wed, 3 Feb 2016 08:25:52 -0500 Received: from mail-vk0-f65.google.com ([209.85.213.65]:35595 "EHLO mail-vk0-f65.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751237AbcBCNZt (ORCPT ); Wed, 3 Feb 2016 08:25:49 -0500 From: Gustavo Padovan To: Greg Kroah-Hartman Cc: linux-kernel@vger.kernel.org, devel@driverdev.osuosl.org, dri-devel@lists.freedesktop.org, Daniel Stone , =?UTF-8?q?Arve=20Hj=C3=B8nnev=C3=A5g?= , Riley Andrews , Daniel Vetter , Rob Clark , Greg Hackmann , John Harrison , Maarten Lankhorst , Gustavo Padovan Subject: [PATCH v3 00/11] android sync framework: clean up IOCTLs and ABI Date: Wed, 3 Feb 2016 11:25:29 -0200 Message-Id: <1454505940-18094-1-git-send-email-gustavo@padovan.org> X-Mailer: git-send-email 2.5.0 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org From: Gustavo Padovan Hi, This patch series clean up IOCTLs and abi of sync framework and it is a follow up on the clean up series I've sent on Jan 21: http://thread.gmane.org/gmane.comp.video.dri.devel/145509 The main changes here are: * remove of SYNC_WAIT ioctl, poll() should be used instead. * rename some structs and macros to better reflect the new internal names. * clean up and improve ABI on SYNC_IOC_FILE_INFO * add flags filed to all ABI structs * make sync_file_info->len return only the size of the array of fence_infos v2: - Check flags passed to the kernel (Maarten) - Rework len to report only the size of fence_infos array (Emil) - Fix fence_info type. Use __u64 pointer type (Emil, Maarten) v3: - Rename fence_info to sync_fence_info (Maarten) - Fix check for info.name (Maarten) - Update commit description of patch 06 (Emil, Maarten) Please review! Thanks. Gustavo Padovan (11): staging/android: remove SYNC_WAIT ioctl staging/android: rename sync_pt_info to sync_fence_info staging/android: rename sync_file_info_data to sync_file_info staging/android: remove driver_data from struct sync_fence_info staging/android: remove len field from struct sync_fence_info staging/android: turn fence_info into a __u64 pointer staging/android: add num_fences field to struct sync_file_info staging/android: make info->len return only size of sync_fence_info array staging/android: rename SYNC_IOC_FENCE_INFO staging/android: add flags member to sync ioctl structs staging/android: remove redundant comments on sync_merge_data drivers/staging/android/sw_sync.c | 14 ---- drivers/staging/android/sync.c | 129 +++++++++-------------------------- drivers/staging/android/sync.h | 20 ------ drivers/staging/android/trace/sync.h | 44 ------------ drivers/staging/android/uapi/sync.h | 50 ++++++-------- 5 files changed, 56 insertions(+), 201 deletions(-) -- 2.5.0