From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1760376AbcBYKjz (ORCPT ); Thu, 25 Feb 2016 05:39:55 -0500 Received: from ozlabs.org ([103.22.144.67]:60007 "EHLO ozlabs.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1759750AbcBYKjx (ORCPT ); Thu, 25 Feb 2016 05:39:53 -0500 Message-ID: <1456396790.15739.11.camel@ellerman.id.au> Subject: Re: [PATCH 05/12] powerpc/ftrace: ftrace_graph_caller() needs to save/restore toc From: Michael Ellerman To: Balbir Singh , linuxppc-dev@ozlabs.org Cc: duwe@lst.de, linux-kernel@vger.kernel.org, rostedt@goodmis.org, kamalesh@linux.vnet.ibm.com, pmladek@suse.com, jeyu@redhat.com, jkosina@suse.cz, live-patching@vger.kernel.org, mbenes@suse.cz Date: Thu, 25 Feb 2016 21:39:50 +1100 In-Reply-To: <56CE4B2E.7070505@gmail.com> References: <1456324115-21144-1-git-send-email-mpe@ellerman.id.au> <1456324115-21144-5-git-send-email-mpe@ellerman.id.au> <56CE4B2E.7070505@gmail.com> Content-Type: text/plain; charset="UTF-8" X-Mailer: Evolution 3.16.5-1ubuntu3.1 Mime-Version: 1.0 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, 2016-02-25 at 11:30 +1100, Balbir Singh wrote: > > On 25/02/16 01:28, Michael Ellerman wrote: > > Signed-off-by: Michael Ellerman > > > > diff --git a/arch/powerpc/kernel/entry_64.S b/arch/powerpc/kernel/entry_64.S > > index 2a7313cfbc7d..9e77a2c8f218 100644 > > --- a/arch/powerpc/kernel/entry_64.S > > +++ b/arch/powerpc/kernel/entry_64.S > > @@ -1237,6 +1237,11 @@ _GLOBAL(ftrace_graph_caller) > > std r5, 64(r1) > > std r4, 56(r1) > > std r3, 48(r1) > > + > > + /* Save callee's TOC in the ABI compliant location */ > > + std r2, 24(r1) > R2_STACK_OFFSET for readability? Hmm, maybe. Personally when I see "24(r1)" what my brain reads is "stack TOC save slot", but maybe I've been spending too much time with powerpc assembly. R2_STACK_OFFSET is actually new, pulled out from the module code by Torsten. Other code uses STK_GOT to mean the same thing. I don't really like either name, so I'll probably leave do a clean up once this is in. cheers