From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932297AbcBZNpz (ORCPT ); Fri, 26 Feb 2016 08:45:55 -0500 Received: from mga11.intel.com ([192.55.52.93]:40508 "EHLO mga11.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754114AbcBZNpx (ORCPT ); Fri, 26 Feb 2016 08:45:53 -0500 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.22,498,1449561600"; d="scan'208";a="911850138" Message-ID: <1456494391.13244.137.camel@linux.intel.com> Subject: Re: [PATCH v1 05/10] ACPI: switch to use generic UUID API From: Andy Shevchenko To: Dan Williams Cc: "Rafael J. Wysocki" , "Theodore Ts'o" , Arnd Bergmann , Greg Kroah-Hartman , Jarkko Sakkinen , Jani Nikula , David Airlie , Benjamin Tissoires , Bjorn Helgaas , Mathias Nyman , Matt Fleming , Lv Zheng , Mark Brown , Zhang Rui , Mika Westerberg , Andrew Morton , Rasmus Villemoes , Linux ACPI , "linux-kernel@vger.kernel.org" , Maling list - DRI developers , linux-efi@vger.kernel.org, linux-api@vger.kernel.org, "linux-nvdimm@lists.01.org" Date: Fri, 26 Feb 2016 15:46:31 +0200 In-Reply-To: References: <1455711448-124103-1-git-send-email-andriy.shevchenko@linux.intel.com> <1455711448-124103-6-git-send-email-andriy.shevchenko@linux.intel.com> Organization: Intel Finland Oy Content-Type: text/plain; charset="UTF-8" X-Mailer: Evolution 3.18.3-1 Mime-Version: 1.0 Content-Transfer-Encoding: 8bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, 2016-02-17 at 09:49 -0800, Dan Williams wrote: > On Wed, Feb 17, 2016 at 4:17 AM, Andy Shevchenko > wrote: > > Instead of opencoding the existing library functions let's use them > > directly. > > > > The conversion fixes a potential bug in int340x_thermal as well > > since we have > > to use memcmp() on binary data. [..] > > +       uuid_le_to_bin(UUID_NFIT_BUS, &nfit_uuid[NFIT_DEV_BUS]); > > +       uuid_le_to_bin(UUID_NFIT_DIMM, &nfit_uuid[NFIT_DEV_DIMM]); > > I don't see the benefit of this change. The benefit is to have less places (ideally one) which provides UUID helper routines for kernel. >   For the NFIT driver we went > through a fire drill trying to make sure the ACPI spec format of a > UUID matched the Linux interpretation, and this change makes that > harder to determine.   How harder? At least you look into one place and see exactly all functions related. Besides this series actually uses the same approach that was used in ACPI. > ACPI drivers should use ACPICA uuid helper > routines in my opinion. As far as I can see ACPICA lacks of needed API. -- Andy Shevchenko Intel Finland Oy