From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S933838AbcECP1z (ORCPT ); Tue, 3 May 2016 11:27:55 -0400 Received: from mout.kundenserver.de ([217.72.192.74]:53218 "EHLO mout.kundenserver.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S933764AbcECP13 (ORCPT ); Tue, 3 May 2016 11:27:29 -0400 From: Arnd Bergmann To: Linus Walleij , Yendapally Reddy Dhananjaya Reddy , Ray Jui , Arnd Bergmann Cc: linux-gpio@vger.kernel.org, linux-kernel@vger.kernel.org Subject: [PATCH 2/2] pinctrl: ns2: rename pinctrl_utils_dt_free_map Date: Tue, 3 May 2016 17:26:54 +0200 Message-Id: <1462289221-861102-2-git-send-email-arnd@arndb.de> X-Mailer: git-send-email 2.7.0 In-Reply-To: <1462289221-861102-1-git-send-email-arnd@arndb.de> References: <1462289221-861102-1-git-send-email-arnd@arndb.de> X-Provags-ID: V03:K0:9Lgp6eZg9W56hdGZldiuKMrJmyhY7xPsKlGkUh+U74CZ5XRGq7t gv80qTk8S/EzdEpC8WnHCcELvKQ9CY1UMMMOFs/xIAs35Cxu9bBSCcOW+njnkTyBrWKHKYi PY4evh22I6M5OA2X65rdexHcLd6HZrt5gfj+CZnfhRe1lbYu1Vv1ZSenOvnTptkPAik1ECW OzrYWddWHPb4oXmIHBMAQ== X-UI-Out-Filterresults: notjunk:1;V01:K0:eRFn2vwyvrY=:TmQgwP9XdfJdLFDaC6hPKg ifCoFcw+qwIAAt6FpIymvV0U+YCDhWkfhiXe2uVXMToPTI2qV6+3eH4gBASgkfmm+FEWIIm0i f2EfdVRvTuDkD18Uqm5RdqeXSgz735X+7RvH2VMVrnVGzpLypqC429sPD6N7BKr+cr3N1KT9S ymYvehg3nFibzfI06HjuZfFJyR/z2WzAFPLYcPay9g7qnUtKdZ+IeJhcAnVT3Jtmxbyh9wnUk LyLi4HZXIGQ0jOwrYN62KuKxj5stFDBwFA9d2fE+zWWx4hP85o01UpgbDdm0FOrGXZCihPiUh YQ7W48YAFYBEkZBPfFVjDcjtmJ+qlsgP3lLemd4k8l51YP/DT4P4FThASlQ4pQ3n4m2E58YCT JvkoL4S3V0ykCQq5sZIbb2Ly5TSogznSvQXIZE+IedxPkBp4TJioHrLJ1d1tDLmUqAmNLSXS1 mNnDKQ/ZlZ2Xqc5iHwlHSmBqLgRRZfmxCM0IVDP1Gup0HK0llkyf8YmPpFpAEM9PipT/xmQMN 8dM8t8ojzUsg2PGTcbK/XYbbN5AicnFvTm1OotVNcJyXvX4artBXYjDPfDUDDypeogIiVTbi/ 0ZTmsaHkATOquGBl4cXCTmTf+MWuTVx1ATmYRriggCMtUYtWviZHhRlmZyMwPl4M9VRvXl4fJ IIKmb34poTz+ZOVYp1nwcQrohfCRm0IlS9k2HtRCyLk+AIzzKdHpmRrwY8O6v+La8Jd8= Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org A conflict of two patches caused a build error when a function got renamed but a new user appeared in the other patch: drivers/pinctrl/bcm/pinctrl-ns2-mux.c:540:17: error: 'pinctrl_utils_dt_free_map' undeclared here (not in a function) .dt_free_map = pinctrl_utils_dt_free_map, ^~~~~~~~~~~~~~~~~~~~~~~~~ This renames the new user of pinctrl_utils_dt_free_map accordingly. Signed-off-by: Arnd Bergmann Fixes: d32f7fd3bbc3 ("pinctrl: Rename pinctrl_utils_dt_free_map to pinctrl_utils_free_map") Fixes: b5aa1006e4a9 ("pinctrl: ns2: add pinmux driver support for Broadcom NS2 SoC") --- drivers/pinctrl/bcm/pinctrl-ns2-mux.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/pinctrl/bcm/pinctrl-ns2-mux.c b/drivers/pinctrl/bcm/pinctrl-ns2-mux.c index 1fd57db52d7b..3fefd14acc3e 100644 --- a/drivers/pinctrl/bcm/pinctrl-ns2-mux.c +++ b/drivers/pinctrl/bcm/pinctrl-ns2-mux.c @@ -537,7 +537,7 @@ static struct pinctrl_ops ns2_pinctrl_ops = { .get_group_pins = ns2_get_group_pins, .pin_dbg_show = ns2_pin_dbg_show, .dt_node_to_map = pinconf_generic_dt_node_to_map_pin, - .dt_free_map = pinctrl_utils_dt_free_map, + .dt_free_map = pinctrl_utils_free_map, }; static int ns2_get_functions_count(struct pinctrl_dev *pctrl_dev) -- 2.7.0