From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752141AbcELW5M (ORCPT ); Thu, 12 May 2016 18:57:12 -0400 Received: from g2t4621.austin.hp.com ([15.73.212.80]:39130 "EHLO g2t4621.austin.hp.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751111AbcELW5L (ORCPT ); Thu, 12 May 2016 18:57:11 -0400 From: Waiman Long To: Peter Zijlstra , Ingo Molnar Cc: linux-kernel@vger.kernel.org, Davidlohr Bueso , Jason Low , Dave Chinner , Peter Hurley , Scott J Norton , Douglas Hatch , Waiman Long Subject: [PATCH v3 0/4] locking/rwsem: Add reader-owned state to the owner field Date: Thu, 12 May 2016 18:56:47 -0400 Message-Id: <1463093811-10684-1-git-send-email-Waiman.Long@hpe.com> X-Mailer: git-send-email 1.7.1 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org v2->v3: - Make minor code changes as suggested by PeterZ & Peter Hurley. - Add 2 minor patches (#2 & #3) to improve the rwsem code - Add a 4th patch to streamline the rwsem_optimistic_spin() code. v1->v2: - Add rwsem_is_reader_owned() helper & rename rwsem_reader_owned() to rwsem_set_reader_owned(). - Add more comments to clarify the purpose of some of the code changes. Patch 1 is the main patch of this series, whereas patches 2 & 3 are just minor patches to improve the efficiency of the rwsem code. Patch 4 streamlines the rwsem_optimistic_spin() to make it simpler. Waiman Long (4): locking/rwsem: Add reader-owned state to the owner field locking/rwsem: Don't wake up one's own task locking/rwsem: Improve reader wakeup code locking/rwsem: Streamline the rwsem_optimistic_spin() code kernel/locking/rwsem-xadd.c | 75 ++++++++++++++++++++++++------------------ kernel/locking/rwsem.c | 8 +++- kernel/locking/rwsem.h | 41 +++++++++++++++++++++++ 3 files changed, 90 insertions(+), 34 deletions(-)