From: Arnd Bergmann <arnd@arndb.de>
To: Felipe Balbi <balbi@kernel.org>
Cc: Arnd Bergmann <arnd@arndb.de>, Andy Gross <andy.gross@linaro.org>,
David Brown <david.brown@linaro.org>,
Peter Chen <Peter.Chen@nxp.com>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Alan Stern <stern@rowland.harvard.edu>,
Mark Brown <broonie@kernel.org>,
Bjorn Andersson <bjorn.andersson@linaro.org>,
linux-kernel@vger.kernel.org, linux-arm-msm@vger.kernel.org,
linux-soc@vger.kernel.org, linux-usb@vger.kernel.org
Subject: [RFC 0/8] usb: phy: msm: various cleanups
Date: Wed, 18 May 2016 23:24:05 +0200 [thread overview]
Message-ID: <1463606653-325131-1-git-send-email-arnd@arndb.de> (raw)
I stumbled over this warning last week, which showed up after I had
removed an incorrect patch from my randconfig build setup:
drivers/usb/phy/phy-msm-usb.c: In function 'msm_otg_probe':
drivers/usb/phy/phy-msm-usb.c:1735:14: error: 'regs[0].consumer' may be used uninitialized in this function [-Werror=maybe-uninitialized]
motg->vddcx = regs[0].consumer;
~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~
drivers/usb/phy/phy-msm-usb.c:1736:14: error: 'regs[1].consumer' may be used uninitialized in this function [-Werror=maybe-uninitialized]
motg->v3p3 = regs[1].consumer;
~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~
drivers/usb/phy/phy-msm-usb.c:1737:14: error: 'regs[2].consumer' may be used uninitialized in this function [-Werror=maybe-uninitialized]
motg->v1p8 = regs[2].consumer;
~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~
Having already fixed the same problem in the phy-qcom-8x16-usb.c
driver before, I tried to do the same thing here, but it turned
out to be somewhat different, and I ended up running into several
unrelated issues in the driver that I now try to fix up.
The series is not tested beyond verifying that it no longer causes
randconfig warnings, and some patches are not entirely obvious.
In particular the ehci-msm and chipidea changes are probably a
good idea, but they actually change the behavior of the drivers
in a way that I cannot verify through inspection alone. The
last patch in the series probably requires some changes to the
devicetree files to go along with it.
Please have a look and test this, provided the patches make sense
conceptually.
Arnd
Arnd Bergmann (8):
usb: phy: move msm_hsusb.h into driver
usb: ehci-msm: call usb_phy_init instead of open-coding it
usb: chipidea: msm: remove open-coded phy init
usb: phy: move TCSR driver into new file
usb: phy: msm: move register definitions into driver
usb: phy: qcom: use bulk regulator interfaces
usb: phy: msm: remove v1p8/v3p3 voltage setting
usb: phy: msm: disable regulator for remove()
drivers/soc/qcom/Kconfig | 6 +
drivers/soc/qcom/Makefile | 1 +
drivers/soc/qcom/qcom-tcsr.c | 57 +++++
drivers/usb/chipidea/ci_hdrc_msm.c | 6 -
drivers/usb/host/ehci-msm.c | 17 +-
drivers/usb/phy/Kconfig | 1 +
drivers/usb/phy/phy-msm-usb.c | 432 ++++++++++++++++++++++++-------------
include/linux/soc/qcom/tcsr.h | 13 ++
include/linux/usb/msm_hsusb.h | 200 -----------------
include/linux/usb/msm_hsusb_hw.h | 77 -------
10 files changed, 367 insertions(+), 443 deletions(-)
create mode 100644 drivers/soc/qcom/qcom-tcsr.c
create mode 100644 include/linux/soc/qcom/tcsr.h
delete mode 100644 include/linux/usb/msm_hsusb.h
delete mode 100644 include/linux/usb/msm_hsusb_hw.h
--
2.7.0
Cc: Andy Gross <andy.gross@linaro.org>
Cc: David Brown <david.brown@linaro.org>
Cc: Peter Chen <Peter.Chen@nxp.com>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: Alan Stern <stern@rowland.harvard.edu>
Cc: Felipe Balbi <balbi@kernel.org>
Cc: Arnd Bergmann <arnd@arndb.de>
Cc: Mark Brown <broonie@kernel.org>
Cc: Bjorn Andersson <bjorn.andersson@linaro.org>
Cc: linux-kernel@vger.kernel.org
Cc: linux-arm-msm@vger.kernel.org
Cc: linux-soc@vger.kernel.org
Cc: linux-usb@vger.kernel.org
next reply other threads:[~2016-05-18 21:24 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-05-18 21:24 Arnd Bergmann [this message]
2016-05-18 21:24 ` [RFC 1/8] usb: phy: move msm_hsusb.h into driver Arnd Bergmann
2016-05-18 21:24 ` [RFC 2/8] usb: ehci-msm: call usb_phy_init instead of open-coding it Arnd Bergmann
2016-05-18 21:24 ` [RFC 3/8] usb: chipidea: msm: remove open-coded phy init Arnd Bergmann
2016-05-18 21:24 ` [RFC 4/8] usb: phy: move TCSR driver into new file Arnd Bergmann
2016-05-19 19:08 ` Andy Gross
2016-05-20 12:24 ` Arnd Bergmann
2016-05-20 12:44 ` Mark Brown
2016-05-20 14:15 ` Arnd Bergmann
2016-05-18 21:24 ` [RFC 5/8] usb: phy: msm: move register definitions into driver Arnd Bergmann
2016-05-18 21:24 ` [RFC 6/8] usb: phy: qcom: use bulk regulator interfaces Arnd Bergmann
2016-05-18 21:24 ` [RFC 7/8] usb: phy: msm: remove v1p8/v3p3 voltage setting Arnd Bergmann
2016-05-18 21:24 ` [RFC 8/8] usb: phy: msm: disable regulator for remove() Arnd Bergmann
[not found] ` <CAL411-q+B0fuFj6XDR4R21qWknnNj1Z=K8MzSyg0dZyEivk5nw@mail.gmail.com>
2016-05-19 15:28 ` [RFC 0/8] usb: phy: msm: various cleanups Andy Gross
2016-06-21 8:14 ` Felipe Balbi
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1463606653-325131-1-git-send-email-arnd@arndb.de \
--to=arnd@arndb.de \
--cc=Peter.Chen@nxp.com \
--cc=andy.gross@linaro.org \
--cc=balbi@kernel.org \
--cc=bjorn.andersson@linaro.org \
--cc=broonie@kernel.org \
--cc=david.brown@linaro.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-soc@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=stern@rowland.harvard.edu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®