mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Quanmin Yan <yanquanmin1@huawei.com>
To: SeongJae Park <sj@kernel.org>
Cc: <akpm@linux-foundation.org>, <damon@lists.linux.dev>,
	<linux-kernel@vger.kernel.org>, <linux-mm@kvack.org>,
	<wangkefeng.wang@huawei.com>, <zuoze1@huawei.com>
Subject: Re: [RFC PATCH mm-next v2 00/12] mm/damon: support ARM32 with LPAE
Date: Thu, 21 Aug 2025 19:19:53 +0800	[thread overview]
Message-ID: <1463effc-bb59-418a-ad9a-8c30784279df@huawei.com> (raw)
In-Reply-To: <20250820222302.88000-1-sj@kernel.org>

Hi SJ,

在 2025/8/21 6:23, SeongJae Park 写道:
> On Wed, 20 Aug 2025 16:06:10 +0800 Quanmin Yan <yanquanmin1@huawei.com> wrote:
>
>> Previously, DAMON's physical address space monitoring only supported
>> memory ranges below 4GB on LPAE-enabled systems. This was due to
>> the use of 'unsigned long' in 'struct damon_addr_range', which is
>> 32-bit on ARM32 even with LPAE enabled[1].
>>
>> To add DAMON support for ARM32 with LPAE enabled, a new core layer
>> parameter called 'addr_unit' was introduced[2]. Operations set layer
>> can translate a core layer address to the real address by multiplying
>> the parameter value to the core layer address. Support of the parameter
>> is up to each operations layer implementation, though. For example,
>> operations set implementations for virtual address space can simply
>> ignore the parameter. Add the support on paddr, which is the DAMON
>> operations set implementation for the physical address space, as we have
>> a clear use case for that.
>>
>> [1]https://lore.kernel.org/all/20250408075553.959388-1-zuoze1@huawei.com/
>> [2]https://lore.kernel.org/all/20250416042551.158131-1-sj@kernel.org/
>>
>> Changes in v2:
> It would be nice if you can also add the link to the previous version, e.g.,
> like the revisions history of
> https://lore.kernel.org/20250819193404.46680-1-sj@kernel.org
>
>> - set DAMOS_PAGEOUT, DAMOS_LRU_[DE]PRIO, DAMOS_MIGRATE_{HOT,COLD} and
>>    DAMOS_STAT stat in core address unit.
>> - pass ctx->min_region value to replace the original synchronization.
>> - drop the DAMOS stats type changes, keep them as 'unsigned long' type.
>> - separate add addr_unit support for DAMON_RECLAIM and LRU_SORT from
>>    this patch series.
> Thank you for continuing this work!
>
>> Quanmin Yan (2):
>>    mm/damon: add damon_ctx->min_region
>>    mm/damon/core: prevent unnecessary overflow in
>>      damos_set_effective_quota()
> I left a few comments.  In essense, let's rename min_region to min_sz_region,
> and separate the last fix from this series.
>
> Other than above, looks good overall.  I think you can drop RFC tag from the
> next version.
>
>
> Thanks,
> SJ
>
Thank you for your guidance on my work. I have published a new patch series,
please review it at [1].

[1] https://lore.kernel.org/all/20250821105159.2503894-1-yanquanmin1@huawei.com/


Best regards,
Quanmin Yan


      reply	other threads:[~2025-08-21 11:19 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-08-20  8:06 Quanmin Yan
2025-08-20  8:06 ` [RFC PATCH mm-next v2 01/12] mm/damon/core: add damon_ctx->addr_unit Quanmin Yan
2025-08-20  8:06 ` [RFC PATCH mm-next v2 02/12] mm/damon/paddr: support addr_unit for access monitoring Quanmin Yan
2025-08-20  8:06 ` [RFC PATCH mm-next v2 03/12] mm/damon/paddr: support addr_unit for DAMOS_PAGEOUT Quanmin Yan
2025-08-20  8:06 ` [RFC PATCH mm-next v2 04/12] mm/damon/paddr: support addr_unit for DAMOS_LRU_[DE]PRIO Quanmin Yan
2025-08-20  8:06 ` [RFC PATCH mm-next v2 05/12] mm/damon/paddr: support addr_unit for MIGRATE_{HOT,COLD} Quanmin Yan
2025-08-20  8:06 ` [RFC PATCH mm-next v2 06/12] mm/damon/paddr: support addr_unit for DAMOS_STAT Quanmin Yan
2025-08-20  8:06 ` [RFC PATCH mm-next v2 07/12] mm/damon/sysfs: implement addr_unit file under context dir Quanmin Yan
2025-08-20  8:06 ` [RFC PATCH mm-next v2 08/12] Docs/mm/damon/design: document 'address unit' parameter Quanmin Yan
2025-08-20  8:06 ` [RFC PATCH mm-next v2 09/12] Docs/admin-guide/mm/damon/usage: document addr_unit file Quanmin Yan
2025-08-20  8:06 ` [RFC PATCH mm-next v2 10/12] Docs/ABI/damon: " Quanmin Yan
2025-08-20 21:37   ` SeongJae Park
2025-08-20  8:06 ` [RFC PATCH mm-next v2 11/12] mm/damon: add damon_ctx->min_region Quanmin Yan
2025-08-20 21:56   ` SeongJae Park
2025-08-20  8:06 ` [RFC PATCH mm-next v2 12/12] mm/damon/core: prevent unnecessary overflow in damos_set_effective_quota() Quanmin Yan
2025-08-20 22:16   ` SeongJae Park
2025-08-20 22:23 ` [RFC PATCH mm-next v2 00/12] mm/damon: support ARM32 with LPAE SeongJae Park
2025-08-21 11:19   ` Quanmin Yan [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1463effc-bb59-418a-ad9a-8c30784279df@huawei.com \
    --to=yanquanmin1@huawei.com \
    --cc=akpm@linux-foundation.org \
    --cc=damon@lists.linux.dev \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=sj@kernel.org \
    --cc=wangkefeng.wang@huawei.com \
    --cc=zuoze1@huawei.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®