From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754173AbcEZO3T (ORCPT ); Thu, 26 May 2016 10:29:19 -0400 Received: from mail-wm0-f66.google.com ([74.125.82.66]:36540 "EHLO mail-wm0-f66.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754104AbcEZO3R (ORCPT ); Thu, 26 May 2016 10:29:17 -0400 From: Salah Triki To: richard@nod.at, dedekind1@gmail.com, adrian.hunter@intel.com Cc: Salah Triki , linux-mtd@lists.infradead.org, linux-kernel@vger.kernel.org Subject: [PATCH V2] fs: ubifs: Replace kmem_cache_alloc/memset with kmem_cache_zalloc Date: Thu, 26 May 2016 15:28:57 +0100 Message-Id: <1464272937-6629-1-git-send-email-salah.triki@acm.org> X-Mailer: git-send-email 1.9.1 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Code is more readable when using kmem_cache_zalloc instead of kmem_cache_alloc/memset. Signed-off-by: Salah Triki --- fs/ubifs/super.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/fs/ubifs/super.c b/fs/ubifs/super.c index 7034995..f509200 100644 --- a/fs/ubifs/super.c +++ b/fs/ubifs/super.c @@ -262,12 +262,10 @@ static struct inode *ubifs_alloc_inode(struct super_block *sb) { struct ubifs_inode *ui; - ui = kmem_cache_alloc(ubifs_inode_slab, GFP_NOFS); + ui = kmem_cache_zalloc(ubifs_inode_slab, GFP_NOFS); if (!ui) return NULL; - memset((void *)ui + sizeof(struct inode), 0, - sizeof(struct ubifs_inode) - sizeof(struct inode)); mutex_init(&ui->ui_mutex); spin_lock_init(&ui->ui_lock); return &ui->vfs_inode; -- 1.9.1