From: YT Shen <yt.shen@mediatek.com>
To: <dri-devel@lists.freedesktop.org>,
Philipp Zabel <p.zabel@pengutronix.de>
Cc: Rob Herring <robh+dt@kernel.org>, Pawel Moll <pawel.moll@arm.com>,
Mark Rutland <mark.rutland@arm.com>,
Ian Campbell <ijc+devicetree@hellion.org.uk>,
Kumar Gala <galak@codeaurora.org>,
Russell King <linux@arm.linux.org.uk>,
David Airlie <airlied@linux.ie>,
Matthias Brugger <matthias.bgg@gmail.com>,
YT Shen <yt.shen@mediatek.com>, CK Hu <ck.hu@mediatek.com>,
Mao Huang <littlecvr@chromium.org>,
Bibby Hsieh <bibby.hsieh@mediatek.com>,
<devicetree@vger.kernel.org>, <linux-kernel@vger.kernel.org>,
<linux-arm-kernel@lists.infradead.org>,
<linux-mediatek@lists.infradead.org>,
<srv_heupstream@mediatek.com>,
Sascha Hauer <kernel@pengutronix.de>, <yingjoe.chen@mediatek.com>,
<emil.l.velikov@gmail.com>, <thierry.reding@gmail.com>
Subject: [RFC v3 0/5] MT2701 DRM support
Date: Thu, 9 Jun 2016 00:03:40 +0800 [thread overview]
Message-ID: <1465401825-43642-1-git-send-email-yt.shen@mediatek.com> (raw)
This is MT2701 DRM support RFC v3, based on 4.7-rc1.
Most codes are the same, except some register changed.
For example:
- DISP_OVL address offset changed, color format definition changed.
- DISP_RDMA fifo size changed.
- DISP_COLOR offset changed.
We add a new component DISP_BLS, and the connection settings are updated.
And we have shadow register support in MT2701.
Changes since v2:
- Rename mtk_ddp_mux_sel to mtk_ddp_sout_sel
- Update mt2701_mtk_ddp_ext components
- Changed to prefix naming
- Reorder the patch series
- Use of_device_get_match_data() to get driver private data
- Use iopoll macros to implement mtk_disp_mutex_acquire()
- Removed empty device tree nodes
Changes since v1:
- Removed BLS bindings and codes, which belong to pwm driver
- Moved mtk_disp_mutex_acquire() just before mtk_crtc_ddp_config()
- Split patch into smaller parts
- Added const keyword to constant structure
- Removed codes for special memory align
The RFC depends on the following patch:
https://patchwork.kernel.org/patch/8832441/ ("dt-bindings: ARM: Mediatek: Document bindings for MT2701"),
https://patchwork.kernel.org/patch/9140487/ ("dt-bindings: pwm: Add MediaTek display PWM bindings"),
https://patchwork.kernel.org/patch/9137919/ ("dt-bindings: mediatek: add descriptions for mediatek mt2701 iommu and smi"),
https://patchwork.kernel.org/patch/9137923/ ("iommu/mediatek: move the common struct into header file"),
https://patchwork.kernel.org/patch/9137921/ ("memory/mediatek: add support for mt2701"),
https://patchwork.kernel.org/patch/9137927/ ("iommu/mediatek: add support for mtk iommu generation one HW"),
https://patchwork.kernel.org/patch/9137931/ ("ARM: dts: mt2701: add iommu/smi dtsi node for mt2701"),
Thanks,
yt.shen
YT Shen (5):
drm/mediatek: rename macros, add chip prefix
drm/mediatek: add *driver_data for different hardware settings
drm/mediatek: add shadow register support
drm/mediatek: add support for Mediatek SoC MT2701
arm: dts: mt2701: Add display subsystem related nodes for MT2701
arch/arm/boot/dts/mt2701.dtsi | 106 +++++++++++++++++++++
drivers/gpu/drm/mediatek/mtk_disp_ovl.c | 32 +++++--
drivers/gpu/drm/mediatek/mtk_disp_rdma.c | 17 +++-
drivers/gpu/drm/mediatek/mtk_drm_crtc.c | 75 +++++++++------
drivers/gpu/drm/mediatek/mtk_drm_ddp.c | 135 ++++++++++++++++++++-------
drivers/gpu/drm/mediatek/mtk_drm_ddp.h | 2 +
drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.c | 35 +++++--
drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.h | 15 +++
drivers/gpu/drm/mediatek/mtk_drm_drv.c | 57 +++++++++--
drivers/gpu/drm/mediatek/mtk_drm_drv.h | 9 ++
10 files changed, 395 insertions(+), 88 deletions(-)
--
1.7.9.5
next reply other threads:[~2016-06-08 16:05 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-06-08 16:03 YT Shen [this message]
2016-06-08 16:03 ` [RFC v3 1/5] drm/mediatek: rename macros, add chip prefix YT Shen
2016-06-08 16:03 ` [RFC v3 2/5] drm/mediatek: add *driver_data for different hardware settings YT Shen
2016-06-08 16:03 ` [RFC v3 3/5] drm/mediatek: add shadow register support YT Shen
2016-06-13 6:43 ` CK Hu
2016-06-20 8:51 ` YT Shen
2016-06-08 16:03 ` [RFC v3 4/5] drm/mediatek: add support for Mediatek SoC MT2701 YT Shen
2016-06-13 5:56 ` CK Hu
2016-06-20 8:53 ` YT Shen
2016-06-08 16:03 ` [RFC v3 5/5] arm: dts: mt2701: Add display subsystem related nodes for MT2701 YT Shen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1465401825-43642-1-git-send-email-yt.shen@mediatek.com \
--to=yt.shen@mediatek.com \
--cc=airlied@linux.ie \
--cc=bibby.hsieh@mediatek.com \
--cc=ck.hu@mediatek.com \
--cc=devicetree@vger.kernel.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=emil.l.velikov@gmail.com \
--cc=galak@codeaurora.org \
--cc=ijc+devicetree@hellion.org.uk \
--cc=kernel@pengutronix.de \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mediatek@lists.infradead.org \
--cc=linux@arm.linux.org.uk \
--cc=littlecvr@chromium.org \
--cc=mark.rutland@arm.com \
--cc=matthias.bgg@gmail.com \
--cc=p.zabel@pengutronix.de \
--cc=pawel.moll@arm.com \
--cc=robh+dt@kernel.org \
--cc=srv_heupstream@mediatek.com \
--cc=thierry.reding@gmail.com \
--cc=yingjoe.chen@mediatek.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®