From: Giovanni Gherdovich <ggherdovich@suse.cz>
To: Peter Zijlstra <peterz@infradead.org>
Cc: Ingo Molnar <mingo@redhat.com>,
Mike Galbraith <mgalbraith@suse.de>,
Stanislaw Gruszka <sgruszka@redhat.com>,
linux-kernel@vger.kernel.org, Mel Gorman <mgorman@suse.com>,
mgorman@techsingularity.net
Subject: Re: [PATCH] sched/cputime: Mitigate performance regression in times()/clock_gettime()
Date: Fri, 05 Aug 2016 09:58:12 +0200 [thread overview]
Message-ID: <1470383892.2094.13.camel@suse.cz> (raw)
In-Reply-To: <20160803103442.GC7141@twins.programming.kicks-ass.net>
On Wed, 2016-08-03 at 12:02 +0200, Peter Zijlstra wrote:
> On Wed, Aug 03, 2016 at 12:04:52AM +0200, Giovanni Gherdovich wrote:
>
> > > > +#if defined(CONFIG_FAIR_GROUP_SCHED)
> > >
> > > This here wants a comment on why we're doing this. Because I'm
> > > sure that if someone were to read this code in a few weeks
> > > they'd go WTF!?
> >
> > I had that config variable set in the machine I was testing on, and
> > thought that for some reason it was related to my observations. I
> > will repeat the experiment without it, and if I obtain the same
> > results I will drop the conditional. Otherwise I will motivate its
> > necessity.
> >
>
> No, I meant we want a comment here explaining the reason for these
> prefetches.
>
> You'll need the #ifdef because se->cfs_rq doesn't exist otherwise.
Oh! Thanks for pointing that out.
> >
> > I post below the snippets of generated code with and without CSE
> > that I got running 'disassemble /m task_sched_runtime' in gdb;
> > you'll see they're identical. If you prefer the explicit hint I'll
> > include it in v2, but it's probably safe to say it isn't needed.
>
> I much prefer the manual CSE, its much more readable.
Ok.
>
> Also, maybe pull the whole thing into a helper function with a
> descriptive name, like:
>
> /*
> * XXX comment on why this is needed goes here...
> */
> static inline void prefetch_curr_exec_start(struct task_struct *p)
> {
> #ifdef CONFIG_FAIR_GROUP_SCHED
> struct sched_entity *curr = (&p->se)->cfs_rq->curr;
>
> prefetch(curr);
> prefetch(&curr->exec_start);
> #endif
> }
Ok.
On Wed, 2016-08-03 at 12:34 +0200, Peter Zijlstra wrote:
> On Wed, Aug 03, 2016 at 12:02:54PM +0200, Peter Zijlstra wrote:
> > /*
> > * XXX comment on why this is needed goes here...
> > */
> > static inline void prefetch_curr_exec_start(struct task_struct *p)
> > {
> > #ifdef CONFIG_FAIR_GROUP_SCHED
> > struct sched_entity *curr = (&p->se)->cfs_rq->curr;
> #else
> struct sched_entity *curr = task_rq(p)->cfs_rq->curr;
> #endif
>
> Would be the 'right' thing for !cgroup stuffs
Ok, thanks. With a bit of help I figured that you actually meant to
write
#else
struct sched_entity *curr = (&task_rq(p)->cfs)->curr;
#endif
Will add that.
V2 is on its way; I previously said I would put "From: Mike" in the
patch header, but since then I discussed with Mike and we agreed that
the patch will be "From: Giovanni" and Suggested-by: Mike.
Regards,
Giovanni
prev parent reply other threads:[~2016-08-05 7:59 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-07-26 14:07 Giovanni Gherdovich
2016-07-26 14:43 ` kbuild test robot
2016-07-27 11:41 ` Giovanni Gherdovich
2016-08-02 10:37 ` Peter Zijlstra
2016-08-02 13:26 ` Mike Galbraith
2016-08-02 22:04 ` Giovanni Gherdovich
2016-08-03 10:02 ` Peter Zijlstra
2016-08-03 10:34 ` Peter Zijlstra
2016-08-05 7:58 ` Giovanni Gherdovich [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1470383892.2094.13.camel@suse.cz \
--to=ggherdovich@suse.cz \
--cc=linux-kernel@vger.kernel.org \
--cc=mgalbraith@suse.de \
--cc=mgorman@suse.com \
--cc=mgorman@techsingularity.net \
--cc=mingo@redhat.com \
--cc=peterz@infradead.org \
--cc=sgruszka@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome