From: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
To: rostedt <rostedt@goodmis.org>
Cc: linux-kernel <linux-kernel@vger.kernel.org>,
Ingo Molnar <mingo@kernel.org>,
Andrew Morton <akpm@linux-foundation.org>,
"Paul E. McKenney" <paulmck@linux.vnet.ibm.com>
Subject: Re: [PATCH 7/5] tracing: Make sure rcu_irq_enter() can work for trace_*_rcuidle() trace events
Date: Fri, 7 Apr 2017 17:19:05 +0000 (UTC) [thread overview]
Message-ID: <1475342880.4473.1491585545139.JavaMail.zimbra@efficios.com> (raw)
In-Reply-To: <20170407130615.2309b96d@gandalf.local.home>
----- On Apr 7, 2017, at 1:06 PM, rostedt rostedt@goodmis.org wrote:
> From: "Steven Rostedt (VMware)" <rostedt@goodmis.org>
>
> Stack tracing discovered that there's a small location inside the RCU
> infrastructure that calling rcu_irq_enter() does not work. As trace events
that -> where
Do you have a link to the lkml thread where this stack tracing discovery
happened ?
> use rcu_irq_enter() it must make sure that it is functionable. A check
I don't think functionable is the word you are looking for here. Perhaps
"must make sure that it can be invoked" ?
> against rcu_irq_enter_disabled() is added with a WARN_ON_ONCE() as no trace
> event should ever be used in that part of RCU. If the warning is triggered,
> then the trace event is ignored.
>
> Cc: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
> Signed-off-by: Steven Rostedt (VMware) <rostedt@goodmis.org>
> ---
> include/linux/tracepoint.h | 2 ++
> 1 file changed, 2 insertions(+)
>
> diff --git a/include/linux/tracepoint.h b/include/linux/tracepoint.h
> index f72fcfe..8baef96 100644
> --- a/include/linux/tracepoint.h
> +++ b/include/linux/tracepoint.h
> @@ -159,6 +159,8 @@ extern void syscall_unregfunc(void);
> TP_PROTO(data_proto), \
> TP_ARGS(data_args), \
> TP_CONDITION(cond), \
> + if (WARN_ON_ONCE(rcu_irq_enter_disabled())) \
> + return; \
I must admit that it's a bit odd to have:
if (WARN_ON_ONCE(rcu_irq_enter_disabled()))
return;
rcu_irq_enter_irqson()
as one argument to the __DO_TRACE() macro. To me it's a bit unexpected
coding-style wise. Am I the only one not comfortable with the proposed
syntax ?
Thanks,
Mathieu
> rcu_irq_enter_irqson(), \
> rcu_irq_exit_irqson()); \
> }
> --
> 2.9.3
--
Mathieu Desnoyers
EfficiOS Inc.
http://www.efficios.com
next prev parent reply other threads:[~2017-04-07 17:18 UTC|newest]
Thread overview: 39+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-04-07 14:01 [PATCH 0/5 v2] tracing: Add usecase of synchronize_rcu_tasks() and stack_tracer_disable() Steven Rostedt
2017-04-07 14:01 ` [PATCH 1/5 v2] ftrace: Add use of synchronize_rcu_tasks() with dynamic trampolines Steven Rostedt
2017-04-07 14:01 ` [PATCH 2/5 v2] tracing: Replace the per_cpu() with this_cpu() in trace_stack.c Steven Rostedt
2017-04-07 14:36 ` Paul E. McKenney
2017-04-07 14:48 ` Steven Rostedt
2017-04-07 15:08 ` Paul E. McKenney
2017-04-07 14:01 ` [PATCH 3/5 v2] tracing: Add stack_tracer_disable/enable() functions Steven Rostedt
2017-04-07 14:22 ` Steven Rostedt
2017-04-07 14:25 ` [PATCH 3/5 v2.1] " Steven Rostedt
2017-04-07 14:01 ` [PATCH 4/5 v2] tracing: Rename trace_active to disable_stack_tracer and inline its modification Steven Rostedt
2017-04-07 14:01 ` [PATCH 5/5 v2] rcu: Fix dyntick-idle tracing Steven Rostedt
2017-04-07 14:40 ` Paul E. McKenney
2017-04-07 14:53 ` Steven Rostedt
2017-04-07 15:09 ` Paul E. McKenney
2017-04-07 15:29 ` Steven Rostedt
2017-04-07 14:43 ` [PATCH 0/5 v2] tracing: Add usecase of synchronize_rcu_tasks() and stack_tracer_disable() Paul E. McKenney
2017-04-07 14:58 ` Steven Rostedt
2017-04-07 15:11 ` Paul E. McKenney
2017-04-07 15:28 ` Steven Rostedt
2017-04-07 16:35 ` [PATCH 6/5]rcu/tracing: Add rcu_disabled to denote when rcu_irq_enter() will not work Steven Rostedt
2017-04-07 16:42 ` Paul E. McKenney
2017-04-07 16:44 ` Steven Rostedt
2017-04-07 16:53 ` Paul E. McKenney
2017-04-07 17:03 ` [PATCH 6/5 v2] rcu/tracing: " Steven Rostedt
2017-04-07 17:15 ` Paul E. McKenney
2017-04-07 17:06 ` [PATCH 7/5] tracing: Make sure rcu_irq_enter() can work for trace_*_rcuidle() trace events Steven Rostedt
2017-04-07 17:15 ` Paul E. McKenney
2017-04-07 17:19 ` Mathieu Desnoyers [this message]
2017-04-07 17:26 ` Steven Rostedt
2017-04-07 17:32 ` Steven Rostedt
2017-04-07 17:49 ` Mathieu Desnoyers
2017-04-07 17:55 ` Steven Rostedt
2017-04-07 18:10 ` [PATCH 7/5 v3] " Steven Rostedt
2017-04-07 18:17 ` Mathieu Desnoyers
2017-04-07 19:41 ` [PATCH 7/5 v4] " Steven Rostedt
2017-04-07 19:43 ` Steven Rostedt
2017-04-10 17:11 ` Mathieu Desnoyers
2017-04-07 17:28 ` [PATCH 7/5] " Steven Rostedt
2017-04-07 17:48 ` [PATCH 7/5 v2] " Steven Rostedt
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1475342880.4473.1491585545139.JavaMail.zimbra@efficios.com \
--to=mathieu.desnoyers@efficios.com \
--cc=akpm@linux-foundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
--cc=paulmck@linux.vnet.ibm.com \
--cc=rostedt@goodmis.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome