From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S942941AbcJ1WFS (ORCPT ); Fri, 28 Oct 2016 18:05:18 -0400 Received: from mga11.intel.com ([192.55.52.93]:63604 "EHLO mga11.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1030427AbcJ1WFN (ORCPT ); Fri, 28 Oct 2016 18:05:13 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.31,560,1473145200"; d="scan'208";a="25003841" From: "Fenghua Yu" To: "Thomas Gleixner" Cc: "Ingo Molnar" , "H. Peter Anvin" , "Tony Luck" , "Borislav Petkov" , "Stephane Eranian" , "Peter Zijlstra" , "Dave Hansen" , "David Carrillo-Cisneros" , "Ravi V Shankar" , "Vikas Shivappa" , "Sai Prakhya" , "Nilay Vaish" , "Shaohua Li" , "linux-kernel" , "x86" , "Fenghua Yu" Subject: [PATCH v6 00/10] Intel Cache Allocation Technology Date: Fri, 28 Oct 2016 15:04:39 -0700 Message-Id: <1477692289-37412-1-git-send-email-fenghua.yu@intel.com> X-Mailer: git-send-email 1.8.0.1 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org From: Fenghua Yu This version is supposed to cover all comments from Thomas. Patch 1-4, 6-9 of 18 v5 patches are in tip x86/cache branch. We have rest of 10 patches in v6 on top of tip tree. Change log in v6: patch 1 (i.e. patch 5 in v5): Change max_cbm_val to cbm_mask. patch 2 (i.e. patch 10 in v5): Change comments for rdt_find_domain and domain_add_cpu() to explain why domain list is sorted by id. Change the pos argument to optional in rdt_rind_domain and assign NULL to it in caller domain_remove_cpu. patch 3 (i.e. patch 11 in v5): Remove arg's type cast in l3_qos_cfg_update(). Change the local variable declaration lines in more readable way. Disable CDP in umount only when it's enabled. Fix an error handling issue in rdt_mount. patch 4 (i.e. patch 12 in v5): Change names from "num_closid" to "num_closids" and from "cbm_val" to "cbm_mask" in res_info_files. Remove the unused label "out" in rdtgroup_setup_root() and will add it later when it's used. patch 5 (i.e. patch 13 in v5): Init closid_free_map by minimal closid instead of by maximum closid in all resources. patch 6 (i.e. patch 14 in v5): Change local variable declaration lines to more readable way. patch 7 (i.e. patch 15 in v5): Change for_each_process to for_each_process_thread patch 8 (i.e. patch 16 in v5): Change local variable declaration lines to more readable way. patch 9 (i.e. patch 17 in v5): No change. patch 10 (i.e. patch 18 in v5): No change. Fenghua Yu (7): Documentation, x86: Documentation for Intel resource allocation user interface x86/intel_rdt: Add basic resctrl filesystem support x86/intel_rdt: Add "info" files to resctrl file system x86/intel_rdt: Add mkdir to resctrl file system x86/intel_rdt: Add tasks files x86/intel_rdt: Add scheduler hook MAINTAINERS: Add maintainer for Intel RDT resource allocation Tony Luck (3): x86/intel_rdt: Build structures for each resource based on cache topology x86/intel_rdt: Add cpus file x86/intel_rdt: Add schemata file Documentation/x86/intel_rdt_ui.txt | 167 +++++ MAINTAINERS | 8 + arch/x86/include/asm/intel_rdt.h | 145 +++++ arch/x86/kernel/cpu/Makefile | 2 +- arch/x86/kernel/cpu/intel_rdt.c | 213 ++++++- arch/x86/kernel/cpu/intel_rdt_rdtgroup.c | 1007 ++++++++++++++++++++++++++++++ arch/x86/kernel/cpu/intel_rdt_schemata.c | 245 ++++++++ arch/x86/kernel/process_32.c | 4 + arch/x86/kernel/process_64.c | 4 + include/linux/sched.h | 3 + include/uapi/linux/magic.h | 1 + 11 files changed, 1797 insertions(+), 2 deletions(-) create mode 100644 Documentation/x86/intel_rdt_ui.txt create mode 100644 arch/x86/kernel/cpu/intel_rdt_rdtgroup.c create mode 100644 arch/x86/kernel/cpu/intel_rdt_schemata.c -- 2.5.0