From: Rasmus Villemoes <linux@rasmusvillemoes.dk>
To: Tejun Heo <tj@kernel.org>, Andrew Morton <akpm@linux-foundation.org>
Cc: linux-kernel@vger.kernel.org,
Lai Jiangshan <jiangshanlai@gmail.com>,
Jens Axboe <axboe@kernel.dk>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Rasmus Villemoes <linux@rasmusvillemoes.dk>
Subject: [RFC 08/10] lib/tida.c: introduce tida_get_above
Date: Thu, 8 Dec 2016 02:23:03 +0100 [thread overview]
Message-ID: <1481160187-9652-9-git-send-email-linux@rasmusvillemoes.dk> (raw)
In-Reply-To: <1481160187-9652-1-git-send-email-linux@rasmusvillemoes.dk>
Some potential users want to impose a minimum on the returned
id. Extend tida_get to accept a start parameter, renaming it to
tida_get_above, and make tida_get a trivial wrapper.
Signed-off-by: Rasmus Villemoes <linux@rasmusvillemoes.dk>
---
include/linux/tida.h | 8 +++++++-
lib/tida.c | 22 +++++++++++++---------
2 files changed, 20 insertions(+), 10 deletions(-)
diff --git a/include/linux/tida.h b/include/linux/tida.h
index 9aa3ad96a632..a76fe01bee0b 100644
--- a/include/linux/tida.h
+++ b/include/linux/tida.h
@@ -19,8 +19,14 @@ struct tida {
void tida_init(struct tida *tida);
void tida_destroy(struct tida *tida);
-int tida_get(struct tida *tida, gfp_t gfp);
+int tida_get_above(struct tida *tida, int start, gfp_t gfp);
void tida_put(struct tida *tida, int id);
+static inline int
+tida_get(struct tida *tida, gfp_t gfp)
+{
+ return tida_get_above(tida, 0, gfp);
+}
+
#endif /* __LINUX_TIDA_H__ */
diff --git a/lib/tida.c b/lib/tida.c
index 1ea0deb6fa64..0d43b207325a 100644
--- a/lib/tida.c
+++ b/lib/tida.c
@@ -23,16 +23,15 @@
*/
static int
-tida_expand(struct tida *tida, gfp_t gfp, unsigned long *flags)
+tida_expand(struct tida *tida, gfp_t gfp, unsigned long *flags, unsigned long minalloc)
__releases(tida->lock)
__acquires(tida->lock)
{
unsigned long newalloc, oldalloc = tida->alloc;
unsigned long *bits;
- newalloc = oldalloc ? 2 * oldalloc : BITS_PER_LONG;
-
spin_unlock_irqrestore(&tida->lock, *flags);
+ newalloc = max(2*oldalloc, round_up(minalloc, BITS_PER_LONG));
bits = kcalloc(BITS_TO_LONGS(newalloc), sizeof(*bits), gfp);
spin_lock_irqsave(&tida->lock, *flags);
@@ -50,29 +49,34 @@ tida_expand(struct tida *tida, gfp_t gfp, unsigned long *flags)
}
int
-tida_get(struct tida *tida, gfp_t gfp)
+tida_get_above(struct tida *tida, int start, gfp_t gfp)
{
unsigned long flags;
- int ret;
+ int ret, from;
+
+ if (WARN_ON_ONCE(start < 0))
+ return -EINVAL;
spin_lock_irqsave(&tida->lock, flags);
while (1) {
/* find_next_zero_bit is fine with a NULL bitmap as long as size is 0 */
- ret = find_next_zero_bit(tida->bits, tida->alloc, tida->hint);
+ from = max(start, tida->hint);
+ ret = find_next_zero_bit(tida->bits, tida->alloc, from);
if (ret < tida->alloc)
break;
- ret = tida_expand(tida, gfp, &flags);
+ ret = tida_expand(tida, gfp, &flags, from + 1);
if (ret < 0)
goto out;
}
__set_bit(ret, tida->bits);
- tida->hint = ret+1;
+ if (start <= tida->hint)
+ tida->hint = ret + 1;
out:
spin_unlock_irqrestore(&tida->lock, flags);
return ret;
}
-EXPORT_SYMBOL_GPL(tida_get);
+EXPORT_SYMBOL_GPL(tida_get_above);
void
tida_put(struct tida *tida, int id)
--
2.1.4
next prev parent reply other threads:[~2016-12-08 1:29 UTC|newest]
Thread overview: 25+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-12-08 1:22 [RFC 00/10] implement alternative and much simpler id allocator Rasmus Villemoes
2016-12-08 1:22 ` [RFC 01/10] lib/idr.c: reused free bitmaps are already clear Rasmus Villemoes
2016-12-08 1:22 ` [RFC 02/10] lib/idr.c: delete useless condition Rasmus Villemoes
2016-12-08 1:22 ` [RFC 03/10] lib/idr.c: only fill ida->idr when needed Rasmus Villemoes
2016-12-08 1:22 ` [RFC 04/10] lib/tida.c: a very simple integer id allocator Rasmus Villemoes
2016-12-08 1:23 ` [RFC 05/10] kernel/workqueue.c: replace id allocator ida with tida Rasmus Villemoes
2016-12-08 1:23 ` [RFC 06/10] block: use tida as small id allocator Rasmus Villemoes
2016-12-08 3:56 ` Jens Axboe
2016-12-08 11:02 ` Greg Kroah-Hartman
2016-12-08 1:23 ` [RFC 07/10] drivers/base/platform.c: use simpler " Rasmus Villemoes
2016-12-08 1:23 ` Rasmus Villemoes [this message]
2016-12-08 1:23 ` [RFC 09/10] drm: " Rasmus Villemoes
2016-12-08 1:23 ` [RFC 10/10] fs/devpts: use tida for id allocation Rasmus Villemoes
2016-12-09 13:49 ` [RFC 00/10] implement alternative and much simpler id allocator Tejun Heo
2016-12-09 22:01 ` Andrew Morton
2016-12-12 17:09 ` Tejun Heo
2016-12-12 17:35 ` Matthew Wilcox
2016-12-12 18:05 ` Tejun Heo
2016-12-16 19:14 ` Matthew Wilcox
2016-12-16 20:32 ` Rasmus Villemoes
2016-12-16 21:09 ` Matthew Wilcox
2016-12-17 13:28 ` Matthew Wilcox
2016-12-22 23:46 ` Rasmus Villemoes
2016-12-23 17:03 ` Matthew Wilcox
2016-12-18 2:42 ` Matthew Wilcox
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1481160187-9652-9-git-send-email-linux@rasmusvillemoes.dk \
--to=linux@rasmusvillemoes.dk \
--cc=akpm@linux-foundation.org \
--cc=axboe@kernel.dk \
--cc=gregkh@linuxfoundation.org \
--cc=jiangshanlai@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=tj@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome