From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751519AbdBJEKN (ORCPT ); Thu, 9 Feb 2017 23:10:13 -0500 Received: from LGEAMRELO12.lge.com ([156.147.23.52]:35604 "EHLO lgeamrelo12.lge.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751467AbdBJEKH (ORCPT ); Thu, 9 Feb 2017 23:10:07 -0500 X-Original-SENDERIP: 156.147.1.125 X-Original-MAILFROM: byungchul.park@lge.com X-Original-SENDERIP: 10.177.222.33 X-Original-MAILFROM: byungchul.park@lge.com From: Byungchul Park To: peterz@infradead.org, mingo@kernel.org Cc: linux-kernel@vger.kernel.org Subject: [PATCH] sched: Enhance readability of iterating wake_list Date: Fri, 10 Feb 2017 13:09:31 +0900 Message-Id: <1486699771-8007-1-git-send-email-byungchul.park@lge.com> X-Mailer: git-send-email 1.9.1 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org This is just for enhancing readability and a trivial one. Please take this only if you agree. -----8<----- >>From bb8cfcaa21ce157fb890a3e878fed2f2b7dadf81 Mon Sep 17 00:00:00 2001 From: Byungchul Park Date: Fri, 10 Feb 2017 12:53:14 +0900 Subject: [PATCH] sched: Enhance readability of iterating wake_list Code for interating wake_list can be simpler so that it becomes more readable and can be seen at a glance. Signed-off-by: Byungchul Park --- kernel/sched/core.c | 18 +++++++----------- 1 file changed, 7 insertions(+), 11 deletions(-) diff --git a/kernel/sched/core.c b/kernel/sched/core.c index d01f9d0..66e7743 100644 --- a/kernel/sched/core.c +++ b/kernel/sched/core.c @@ -1769,6 +1769,11 @@ static int ttwu_remote(struct task_struct *p, int wake_flags) } #ifdef CONFIG_SMP +#define for_each_wake_list(task, node) \ + for ((task) = llist_entry((node), struct task_struct, wake_entry); \ + node; (node) = llist_next(node), \ + (task) = llist_entry((node), struct task_struct, wake_entry)) + void sched_ttwu_pending(void) { struct rq *rq = this_rq(); @@ -1783,17 +1788,8 @@ void sched_ttwu_pending(void) raw_spin_lock_irqsave(&rq->lock, flags); rq_pin_lock(rq, &rf); - while (llist) { - int wake_flags = 0; - - p = llist_entry(llist, struct task_struct, wake_entry); - llist = llist_next(llist); - - if (p->sched_remote_wakeup) - wake_flags = WF_MIGRATED; - - ttwu_do_activate(rq, p, wake_flags, &rf); - } + for_each_wake_list(p, llist) + ttwu_do_activate(rq, p, p->sched_remote_wakeup ? WF_MIGRATED : 0, &rf); rq_unpin_lock(rq, &rf); raw_spin_unlock_irqrestore(&rq->lock, flags); -- 1.9.1