From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753168AbdBNN7l (ORCPT ); Tue, 14 Feb 2017 08:59:41 -0500 Received: from smtprelay0234.hostedemail.com ([216.40.44.234]:43495 "EHLO smtprelay.hostedemail.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1752222AbdBNN6L (ORCPT ); Tue, 14 Feb 2017 08:58:11 -0500 X-Session-Marker: 6A6F6540706572636865732E636F6D X-Spam-Summary: 2,0,0,,d41d8cd98f00b204,joe@perches.com,:::::::::,RULES_HIT:41:355:379:541:599:800:960:973:988:989:1260:1277:1311:1313:1314:1345:1359:1373:1437:1515:1516:1518:1534:1540:1593:1594:1711:1714:1730:1747:1777:1792:2198:2199:2393:2559:2562:2828:3138:3139:3140:3141:3142:3351:3622:3865:3866:4321:5007:6119:7514:10004:10400:10848:11026:11232:11473:11658:11914:12043:12438:12555:12740:12760:12895:12986:13069:13311:13357:13439:14181:14659:14721:21080:21451:30054:30091,0,RBL:none,CacheIP:none,Bayesian:0.5,0.5,0.5,Netcheck:none,DomainCache:0,MSF:not bulk,SPF:fn,MSBL:0,DNSBL:none,Custom_rules:0:0:0,LFtime:3,LUA_SUMMARY:none X-HE-Tag: nest21_63783b9571743 X-Filterd-Recvd-Size: 1769 Message-ID: <1487080682.6214.25.camel@perches.com> Subject: Re: [PATCH] Power: Supply: sbs-charger: simplfied bool function From: Joe Perches To: Daniel Perez , sre@kernel.org Cc: linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org, nicolassaenzj@gmail.com Date: Tue, 14 Feb 2017 05:58:02 -0800 In-Reply-To: <1487079790-724-1-git-send-email-danielperezdeandres@gmail.com> References: <1487079790-724-1-git-send-email-danielperezdeandres@gmail.com> Content-Type: text/plain; charset="ISO-8859-1" X-Mailer: Evolution 3.22.3-0ubuntu0.1 Mime-Version: 1.0 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, 2017-02-14 at 14:43 +0100, Daniel Perez wrote: > Simplified the syntax of a simple bool return value function. > > Signed-off-by: Daniel Perez > --- > drivers/power/supply/sbs-charger.c | 5 +---- > 1 file changed, 1 insertion(+), 4 deletions(-) > > diff --git a/drivers/power/supply/sbs-charger.c b/drivers/power/supply/sbs-charger.c > index 353765a..3e40553 100644 > --- a/drivers/power/supply/sbs-charger.c > +++ b/drivers/power/supply/sbs-charger.c > @@ -137,10 +137,7 @@ static enum power_supply_property sbs_properties[] = { > > static bool sbs_readable_reg(struct device *dev, unsigned int reg) > { > - if (reg < SBS_CHARGER_REG_SPEC_INFO) > - return false; > - else > - return true; > + return reg < SBS_CHARGER_REG_SPEC_INFO ? false : true; Any ternary with true false could be simplified. Why not just return reg >= SBS_CHARGER_REG_SPEC_INFO;