From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751474AbdBXTg1 (ORCPT ); Fri, 24 Feb 2017 14:36:27 -0500 Received: from mga02.intel.com ([134.134.136.20]:60794 "EHLO mga02.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751265AbdBXTgV (ORCPT ); Fri, 24 Feb 2017 14:36:21 -0500 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.35,201,1484035200"; d="scan'208";a="52458239" Message-ID: <1487964979.115017.11.camel@ranerica-desktop> Subject: Re: [PATCH v4 15/17] x86/traps: Fixup general protection faults caused by UMIP From: Ricardo Neri To: Andy Lutomirski Cc: Peter Zijlstra , Ingo Molnar , Thomas Gleixner , "H. Peter Anvin" , Andy Lutomirski , Borislav Petkov , Andrew Morton , Brian Gerst , Chris Metcalf , Dave Hansen , Paolo Bonzini , Liang Z Li , Masami Hiramatsu , Huang Rui , Jiri Slaby , Jonathan Corbet , "Michael S. Tsirkin" , Paul Gortmaker , Vlastimil Babka , Chen Yucong , Alexandre Julliard , Stas Sergeev , Fenghua Yu , "Ravi V. Shankar" , Shuah Khan , "linux-kernel@vger.kernel.org" , X86 ML , linux-msdos@vger.kernel.org, wine-devel@winehq.org, Tony Luck Date: Fri, 24 Feb 2017 11:36:19 -0800 In-Reply-To: References: <20170223063706.71554-1-ricardo.neri-calderon@linux.intel.com> <20170223063706.71554-16-ricardo.neri-calderon@linux.intel.com> <20170223092724.GZ6515@twins.programming.kicks-ass.net> <1487888144.115017.3.camel@ranerica-desktop> Content-Type: text/plain; charset="UTF-8" X-Mailer: Evolution 3.10.4-0ubuntu2 Mime-Version: 1.0 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, 2017-02-24 at 11:11 -0800, Andy Lutomirski wrote: > > In a previous version Andy Lutomirsky suggested that > > if (user_mode(regs) && (fixup_umip_exception(regs) == 0)) > > > > was easier to read :). Although at the time fixup_umip_exception > > returned a numeric value. Now it only returns true/false for > > successful/failed emulation. If with true/false not comparing to > true > > makes it easier to read, I will make the change. > > I think == true is silly :) Then I'll make the change. Thanks and BR, Ricardo