From: Daniel Lezcano <daniel.lezcano@linaro.org>
To: tglx@linutronix.de
Cc: linux-kernel@vger.kernel.org
Subject: [PATCH 17/23] clocksource/drivers: Rename CLKSRC_ACPI to TIMER_ACPI
Date: Wed, 14 Jun 2017 14:39:38 +0200 [thread overview]
Message-ID: <1497443984-12371-17-git-send-email-daniel.lezcano@linaro.org> (raw)
In-Reply-To: <1497443984-12371-1-git-send-email-daniel.lezcano@linaro.org>
The config option name is now renamed to 'TIMER_ACPI' for consistency with
the CLOCKSOURCE_OF_DECLARE => TIMER_OF_DECLARE change.
Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>
Reviewed-by: Linus Walleij <linus.walleij@linaro.org>
---
drivers/clocksource/Kconfig | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/clocksource/Kconfig b/drivers/clocksource/Kconfig
index 90f062e..4ba230d 100644
--- a/drivers/clocksource/Kconfig
+++ b/drivers/clocksource/Kconfig
@@ -5,7 +5,7 @@ config TIMER_OF
bool
select TIMER_PROBE
-config CLKSRC_ACPI
+config TIMER_ACPI
bool
select TIMER_PROBE
@@ -310,7 +310,7 @@ config ARC_TIMERS_64BIT
config ARM_ARCH_TIMER
bool
select TIMER_OF if OF
- select CLKSRC_ACPI if ACPI
+ select TIMER_ACPI if ACPI
config ARM_ARCH_TIMER_EVTSTREAM
bool "Enable ARM architected timer event stream generation by default"
--
2.7.4
next prev parent reply other threads:[~2017-06-14 12:44 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-06-14 12:38 [GIT PULL] clockevents for 4.13 Daniel Lezcano
2017-06-14 12:39 ` [PATCH 01/23] arm: aspeed: Add clock-names property to timer node Daniel Lezcano
2017-06-14 12:39 ` [PATCH 02/23] clocksource/drivers/fttmr010: Fix the clock handling Daniel Lezcano
2017-06-14 12:39 ` [PATCH 03/23] clocksource/drivers/fttmr010: Merge FTTMR010 DT bindings Daniel Lezcano
2017-06-14 12:39 ` [PATCH 04/23] clocksource/drivers/fttmr010: Drop Gemini specifics Daniel Lezcano
2017-06-14 12:39 ` [PATCH 05/23] clocksource/drivers/fttmr010: Use state container Daniel Lezcano
2017-06-14 12:39 ` [PATCH 06/23] clocksource/drivers/fttmr010: Switch to use bitops Daniel Lezcano
2017-06-14 12:39 ` [PATCH 07/23] clocksource/drivers/fttmr010: Switch to use TIMER2 src Daniel Lezcano
2017-06-14 12:39 ` [PATCH 08/23] clocksource/drivers/fttmr010: Merge Moxa into FTTMR010 Daniel Lezcano
2017-06-14 12:39 ` [PATCH 09/23] clocksource/drivers/fttmr010: Add AST2500 compatible string Daniel Lezcano
2017-06-14 12:39 ` [PATCH 10/23] clocksource/drivers/fttmr010: Fix aspeed-2500 initialization Daniel Lezcano
2017-06-14 12:39 ` [PATCH 11/23] Revert "clockevents: Add a clkevt-of mechanism like clksrc-of" Daniel Lezcano
2017-06-14 12:39 ` [PATCH 14/23] clocksource/drivers: Rename CLOCKSOURCE_ACPI_DECLARE to TIMER_ACPI_DECLARE Daniel Lezcano
2017-06-14 12:39 ` [PATCH 15/23] clocksource/drivers: Rename clksrc table to timer Daniel Lezcano
2017-06-14 12:39 ` [PATCH 16/23] clocksource/drivers: Rename CLKSRC_OF to TIMER_OF Daniel Lezcano
2017-06-14 12:39 ` Daniel Lezcano [this message]
2017-06-14 12:39 ` [PATCH 18/23] clocksource/drivers: Add an alias macro CLOCKSOURCE_OF_DECLARE Daniel Lezcano
2017-06-14 12:39 ` [PATCH 19/23] clocksource/drivers/fttmr010: Optimize sched_clock() Daniel Lezcano
2017-06-14 12:39 ` [PATCH 20/23] clocksource/drivers/tcb_clksrc: Save timer context on suspend/resume Daniel Lezcano
2017-06-14 12:39 ` [PATCH 21/23] clocksource/drivers: Add timer-of common init routine Daniel Lezcano
2017-06-14 12:39 ` [PATCH 22/23] clocksource/drivers/fttmr010: Implement delay timer Daniel Lezcano
2017-06-14 12:39 ` [PATCH 23/23] clocksource/drivers/fttmr010: Factor out clock read code Daniel Lezcano
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1497443984-12371-17-git-send-email-daniel.lezcano@linaro.org \
--to=daniel.lezcano@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®