From: Masahiro Yamada <yamada.masahiro@socionext.com>
To: linux-mtd@lists.infradead.org
Cc: Masahiro Yamada <yamada.masahiro@socionext.com>,
Cyrille Pitchen <cyrille.pitchen@wedev4u.fr>,
Josh Wu <rainyfeeling@outlook.com>,
Wan ZongShun <mcuos.com@gmail.com>,
linux-kernel@vger.kernel.org,
Boris Brezillon <boris.brezillon@free-electrons.com>,
Marek Vasut <marek.vasut@gmail.com>,
Brian Norris <computersforpeace@gmail.com>,
Richard Weinberger <richard@nod.at>,
David Woodhouse <dwmw2@infradead.org>,
Wenyou Yang <wenyou.yang@atmel.com>,
linux-arm-kernel@lists.infradead.org
Subject: [PATCH 0/2] mtd: nand: introduce NAND_ROW_ADDR_3 flag and improve Denali driver
Date: Tue, 12 Sep 2017 11:37:29 +0900 [thread overview]
Message-ID: <1505183851-29355-1-git-send-email-yamada.masahiro@socionext.com> (raw)
Currently, Denali NAND driver always expects 3 row address cycle
devices because the driver init code hard-code the register setting.
I will fix it in 2/2.
Many drivers check chip->chipsize if the third row address cycle
is needed or not. This is not nice because 32MB, 128MB are
magic numbers. nand_scan_ident can decide it and provide a
driver-friendly flag.
1/2 is touching verious drivers.
I hope Acked-by from driver maintainers if this change looks good.
Masahiro Yamada (2):
mtd: nand: introduce NAND_ROW_ADDR_3 flag
mtd: nand: denali: support two row address cycle devices
drivers/mtd/nand/atmel/nand-controller.c | 3 +--
drivers/mtd/nand/au1550nd.c | 3 +--
drivers/mtd/nand/denali.c | 4 ++--
drivers/mtd/nand/diskonchip.c | 3 +--
drivers/mtd/nand/hisi504_nand.c | 3 +--
drivers/mtd/nand/mxc_nand.c | 3 +--
drivers/mtd/nand/nand_base.c | 9 +++++----
drivers/mtd/nand/nuc900_nand.c | 2 +-
include/linux/mtd/rawnand.h | 3 +++
9 files changed, 16 insertions(+), 17 deletions(-)
--
2.7.4
next reply other threads:[~2017-09-12 2:40 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-09-12 2:37 Masahiro Yamada [this message]
2017-09-12 2:37 ` [PATCH 1/2] mtd: nand: introduce NAND_ROW_ADDR_3 flag Masahiro Yamada
2017-09-13 1:20 ` kbuild test robot
2017-09-12 2:37 ` [PATCH 2/2] mtd: nand: denali: support two row address cycle devices Masahiro Yamada
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1505183851-29355-1-git-send-email-yamada.masahiro@socionext.com \
--to=yamada.masahiro@socionext.com \
--cc=boris.brezillon@free-electrons.com \
--cc=computersforpeace@gmail.com \
--cc=cyrille.pitchen@wedev4u.fr \
--cc=dwmw2@infradead.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mtd@lists.infradead.org \
--cc=marek.vasut@gmail.com \
--cc=mcuos.com@gmail.com \
--cc=rainyfeeling@outlook.com \
--cc=richard@nod.at \
--cc=wenyou.yang@atmel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®