From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751697AbdJEH7F (ORCPT ); Thu, 5 Oct 2017 03:59:05 -0400 Received: from lb1-smtp-cloud9.xs4all.net ([194.109.24.22]:33967 "EHLO lb1-smtp-cloud9.xs4all.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751366AbdJEH7D (ORCPT ); Thu, 5 Oct 2017 03:59:03 -0400 Message-ID: <1507190336.2167.5.camel@tiscali.nl> Subject: Re: [PATCH] isdn/gigaset: Convert timers to use timer_setup() From: Paul Bolle To: Kees Cook Cc: Karsten Keil , "David S. Miller" , Johan Hovold , gigaset307x-common@lists.sourceforge.net, netdev@vger.kernel.org, Thomas Gleixner , linux-kernel@vger.kernel.org Date: Thu, 05 Oct 2017 09:58:56 +0200 In-Reply-To: <20171005005212.GA23556@beast> References: <20171005005212.GA23556@beast> Content-Type: text/plain; charset="UTF-8" X-Mailer: Evolution 3.24.5 (3.24.5-1.fc26) Mime-Version: 1.0 Content-Transfer-Encoding: 7bit X-CMAE-Envelope: MS4wfNj6OFoiatAC51iF7dHg7FQaXTMMj7vhlIju18erzlb+BsBEy6MHxcmNvJr0FtcYqIxntqW2cXZXEKRW31M2NWXNDEPy1NOyHGiEvNd1odeO8yktzl/a 6JI8xo3o3+rCA9dh518bzPkBkjHfUAD3Vu0Van+bTL9U1YiYpltVudBxaCeT8oFmZt+ed8vEfcdxhQythdtrY2XukJkRXm7dFS3zwf+s4WQB6dJbrtA/UFcf dgLhPDuCPYKCiB09omzMIBuxmDejfxaUkewRCXAxLnG7dGwBdAFvY7zcz9t8c2DxH/qx+k4oS7LXCxg1ackMoxlB2KA/lQzSUdm3fe5lrGgpLSyp/RK37Y7c RCLLrJHPk0aigD8Rw79O+3TE0L1aAzR4d7GqoUwpkTJD3DEjfhpQYoKGAWwLBdB9rTri1QkMXngRCEDhejbNPavU1Tl7xXApqqFcde+vtKz0KfSKyLM= Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi Kees, On Wed, 2017-10-04 at 17:52 -0700, Kees Cook wrote: > Also uses kzmalloc to replace open-coded field assignments to NULL and zero. If I'm allowed to whine (chances that I'm allowed to do that are not so great as Dave tends to apply gigaset patches before I even have a chance to look at them properly!): I'd prefer it if that was done separately in a preceding patch. Would that bother you? Thanks, Paul Bolle