From: Petr Mladek <pmladek@suse.com>
To: Jiri Kosina <jikos@kernel.org>, Joe Lawrence <joe.lawrence@redhat.com>
Cc: Josh Poimboeuf <jpoimboe@redhat.com>,
Jessica Yu <jeyu@kernel.org>, Miroslav Benes <mbenes@suse.cz>,
Chris J Arges <chris.j.arges@canonical.com>,
live-patching@vger.kernel.org, linux-kernel@vger.kernel.org,
Petr Mladek <pmladek@suse.com>
Subject: [PATCH 1/2] livepatch: Correctly call klp_post_unpatch_callback() in error paths
Date: Fri, 20 Oct 2017 16:56:50 +0200 [thread overview]
Message-ID: <1508511411-4189-2-git-send-email-pmladek@suse.com> (raw)
In-Reply-To: <1508511411-4189-1-git-send-email-pmladek@suse.com>
The flag post_unpatch_enabled in struct klp_callbacks is need in
the error paths. We need to call the post_unpatch callback
only when the pre_patch one was called.
We should clear the flag in klp_post_unpatch_callback() to make
sure that the callback is not called twice. It makes the API
more safe.
Note that we actually would call the callback twice in
klp_module_coming() when klp_patch_object() fails.
In this case, we explicitly call klp_post_unpatch_callback()
for the failed object. And we are going to call it once
again when reverting operations for all the patches by
reusing the klp_module_going() code. There is a patch
doing this in the queue.
There was another mistake in the error path in klp_comming_module().
It called klp_post_unpatch_callback() only when
patch != klp_transition_patch. But klp_pre_patch_callback()
was called even for this patch.
In fact, we could remove klp_post_unpatch_callback() from
the error path at all because it will be covered by
the reuse of the klp_module_going() code. But I think
that it is cleaner this way. For example, someone
might later decide to call the callback only when
obj->patched flag is set.
Finally, I used this opportunity to make klp_pre_patch_callback()
more readable.
Signed-off-by: Petr Mladek <pmladek@suse.com>
---
kernel/livepatch/core.c | 4 +---
kernel/livepatch/core.h | 8 +++++---
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/kernel/livepatch/core.c b/kernel/livepatch/core.c
index cafb5a84417d..eb134479c394 100644
--- a/kernel/livepatch/core.c
+++ b/kernel/livepatch/core.c
@@ -894,9 +894,7 @@ int klp_module_coming(struct module *mod)
pr_warn("failed to apply patch '%s' to module '%s' (%d)\n",
patch->mod->name, obj->mod->name, ret);
- if (patch != klp_transition_patch)
- klp_post_unpatch_callback(obj);
-
+ klp_post_unpatch_callback(obj);
goto err;
}
diff --git a/kernel/livepatch/core.h b/kernel/livepatch/core.h
index 6fc907b54e71..cc3aa708e0b4 100644
--- a/kernel/livepatch/core.h
+++ b/kernel/livepatch/core.h
@@ -12,10 +12,10 @@ static inline bool klp_is_object_loaded(struct klp_object *obj)
static inline int klp_pre_patch_callback(struct klp_object *obj)
{
- int ret;
+ int ret = 0;
- ret = (obj->callbacks.pre_patch) ?
- (*obj->callbacks.pre_patch)(obj) : 0;
+ if (obj->callbacks.pre_patch)
+ ret = (*obj->callbacks.pre_patch)(obj);
obj->callbacks.post_unpatch_enabled = !ret;
@@ -39,6 +39,8 @@ static inline void klp_post_unpatch_callback(struct klp_object *obj)
if (obj->callbacks.post_unpatch_enabled &&
obj->callbacks.post_unpatch)
(*obj->callbacks.post_unpatch)(obj);
+
+ obj->callbacks.post_unpatch_enabled = false;
}
#endif /* _LIVEPATCH_CORE_H */
--
1.8.5.6
next prev parent reply other threads:[~2017-10-20 14:57 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-10-20 14:56 [PATCH 0/2] livepatch: Additional fixes for callbacks feature Petr Mladek
2017-10-20 14:56 ` Petr Mladek [this message]
2017-10-24 18:33 ` [PATCH 1/2] livepatch: Correctly call klp_post_unpatch_callback() in error paths Joe Lawrence
2017-10-20 14:56 ` [PATCH 2/2] livepatch: __klp_disable_patch() should never be called for disabled patches Petr Mladek
2017-10-24 14:27 ` Joe Lawrence
2017-11-01 10:10 ` Miroslav Benes
2017-10-26 12:59 ` [PATCH 0/2] livepatch: Additional fixes for callbacks feature Jiri Kosina
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1508511411-4189-2-git-send-email-pmladek@suse.com \
--to=pmladek@suse.com \
--cc=chris.j.arges@canonical.com \
--cc=jeyu@kernel.org \
--cc=jikos@kernel.org \
--cc=joe.lawrence@redhat.com \
--cc=jpoimboe@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=live-patching@vger.kernel.org \
--cc=mbenes@suse.cz \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome