From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1757351AbdKOJ2z convert rfc822-to-8bit (ORCPT ); Wed, 15 Nov 2017 04:28:55 -0500 Received: from mx0b-001b2d01.pphosted.com ([148.163.158.5]:50414 "EHLO mx0a-001b2d01.pphosted.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1757052AbdKOJ2n (ORCPT ); Wed, 15 Nov 2017 04:28:43 -0500 Date: Wed, 15 Nov 2017 14:58:33 +0530 From: "Naveen N. Rao" Subject: Re: [PATCH v4 2/3] powerpc/modules: Don't try to restore r2 after a sibling call To: Josh Poimboeuf Cc: Balbir Singh , Kamalesh Babulal , linux-kernel@vger.kernel.org, linuxppc-dev@lists.ozlabs.org, live-patching@vger.kernel.org, Michael Ellerman References: <20171114092910.20399-1-kamalesh@linux.vnet.ibm.com> <20171114092910.20399-3-kamalesh@linux.vnet.ibm.com> <1510654928.8xrjtkjm8m.naveen@linux.ibm.com> <20171114155323.3sjxx3eykinnl2ea@treble> In-Reply-To: <20171114155323.3sjxx3eykinnl2ea@treble> User-Agent: astroid/0.10.2 (https://github.com/astroidmail/astroid) MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8; format=flowed Content-Transfer-Encoding: 8BIT X-TM-AS-GCONF: 00 x-cbid: 17111509-0012-0000-0000-0000058D84C0 X-IBM-AV-DETECTION: SAVI=unused REMOTE=unused XFE=unused x-cbparentid: 17111509-0013-0000-0000-000019084193 Message-Id: <1510737417.g8rnjuztlf.naveen@linux.ibm.com> X-Proofpoint-Virus-Version: vendor=fsecure engine=2.50.10432:,, definitions=2017-11-15_04:,, signatures=0 X-Proofpoint-Spam-Details: rule=outbound_notspam policy=outbound score=0 priorityscore=1501 malwarescore=0 suspectscore=2 phishscore=0 bulkscore=0 spamscore=0 clxscore=1015 lowpriorityscore=0 impostorscore=0 adultscore=0 classifier=spam adjust=0 reason=mlx scancount=1 engine=8.0.1-1709140000 definitions=main-1711150132 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Josh Poimboeuf wrote: > On Tue, Nov 14, 2017 at 03:59:21PM +0530, Naveen N. Rao wrote: >> Kamalesh Babulal wrote: >> > From: Josh Poimboeuf >> > >> > When attempting to load a livepatch module, I got the following error: >> > >> > module_64: patch_module: Expect noop after relocate, got 3c820000 >> > >> > The error was triggered by the following code in >> > unregister_netdevice_queue(): >> > >> > 14c: 00 00 00 48 b 14c >> > 14c: R_PPC64_REL24 net_set_todo >> > 150: 00 00 82 3c addis r4,r2,0 >> > >> > GCC didn't insert a nop after the branch to net_set_todo() because it's >> > a sibling call, so it never returns. The nop isn't needed after the >> > branch in that case. >> > >> > Signed-off-by: Josh Poimboeuf >> > Signed-off-by: Kamalesh Babulal >> > --- >> > arch/powerpc/kernel/module_64.c | 4 ++++ >> > 1 file changed, 4 insertions(+) >> > >> > diff --git a/arch/powerpc/kernel/module_64.c b/arch/powerpc/kernel/module_64.c >> > index 39b01fd..9e5391f 100644 >> > --- a/arch/powerpc/kernel/module_64.c >> > +++ b/arch/powerpc/kernel/module_64.c >> > @@ -489,6 +489,10 @@ static int restore_r2(u32 *instruction, struct module *me) >> > if (is_early_mcount_callsite(instruction - 1)) >> > return 1; >> > >> > + /* Sibling calls don't return, so they don't need to restore r2 */ >> > + if (instruction[-1] == PPC_INST_BRANCH) >> > + return 1; >> > + >> >> This looks quite fragile, unless we know for sure that gcc will _always_ >> emit this instruction form for sibling calls with relocations. >> >> As an alternative, does it make sense to do the following check instead? >> if ((instr_is_branch_iform(insn) || instr_is_branch_bform(insn)) >> && !(insn & 0x1)) > > Yes, good point. How about something like this? That looks good to me (with a very minor nit below). Acked-by: Naveen N. Rao > > (completely untested because I don't have access to a box at the moment) > > > diff --git a/arch/powerpc/include/asm/code-patching.h b/arch/powerpc/include/asm/code-patching.h > index abef812de7f8..302e4368debc 100644 > --- a/arch/powerpc/include/asm/code-patching.h > +++ b/arch/powerpc/include/asm/code-patching.h > @@ -33,6 +33,7 @@ int patch_branch(unsigned int *addr, unsigned long target, int flags); > int patch_instruction(unsigned int *addr, unsigned int instr); > > int instr_is_relative_branch(unsigned int instr); > +int instr_is_link_branch(unsigned int instr); > int instr_is_branch_to_addr(const unsigned int *instr, unsigned long addr); > unsigned long branch_target(const unsigned int *instr); > unsigned int translate_branch(const unsigned int *dest, > diff --git a/arch/powerpc/kernel/module_64.c b/arch/powerpc/kernel/module_64.c > index 9cb007bc7075..b5148a206b4d 100644 > --- a/arch/powerpc/kernel/module_64.c > +++ b/arch/powerpc/kernel/module_64.c > @@ -487,11 +487,13 @@ static bool is_early_mcount_callsite(u32 *instruction) > restore r2. */ > static int restore_r2(u32 *instruction, struct module *me) > { > - if (is_early_mcount_callsite(instruction - 1)) > + u32 *prev_insn = instruction - 1; > + > + if (is_early_mcount_callsite(prev_insn)) > return 1; > > /* Sibling calls don't return, so they don't need to restore r2 */ > - if (instruction[-1] == PPC_INST_BRANCH) > + if (!instr_is_link_branch(*prev_insn)) > return 1; > > if (*instruction != PPC_INST_NOP) { > diff --git a/arch/powerpc/lib/code-patching.c b/arch/powerpc/lib/code-patching.c > index c9de03e0c1f1..4727fafd37e4 100644 > --- a/arch/powerpc/lib/code-patching.c > +++ b/arch/powerpc/lib/code-patching.c > @@ -304,6 +304,12 @@ int instr_is_relative_branch(unsigned int instr) > return instr_is_branch_iform(instr) || instr_is_branch_bform(instr); > } > > +int instr_is_link_branch(unsigned int instr) > +{ > + return (instr_is_branch_iform(instr) || instr_is_branch_bform(instr)) && > + (instr & BRANCH_SET_LINK); > +} > + Nitpicking here, but since we're not considering the other branch forms, perhaps this can be renamed to instr_is_link_relative_branch() (or maybe instr_is_relative_branch_link()), just so we're clear :) - Naveen > static unsigned long branch_iform_target(const unsigned int *instr) > { > signed long imm; > -- > To unsubscribe from this list: send the line "unsubscribe live-patching" in > the body of a message to majordomo@vger.kernel.org > More majordomo info at http://vger.kernel.org/majordomo-info.html > >