From: Joe Perches <joe@perches.com>
To: Shreeya Patel <shreeya.patel23498@gmail.com>,
gregkh@linuxfoundation.org, devel@driverdev.osuosl.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/4] Staging: rtl8723bs: Replace true with x and false with !x
Date: Sun, 17 Dec 2017 01:45:52 -0800 [thread overview]
Message-ID: <1513503952.31581.24.camel@perches.com> (raw)
In-Reply-To: <6a57c658e7e0e66c9d7e9496769593cad4399647.1513501505.git.shreeya.patel23498@gmail.com>
On Sun, 2017-12-17 at 15:07 +0530, Shreeya Patel wrote:
> Replace true and false keywords with "x" and "!x"
> respectively to follow the kernel coding style.
[]
> diff --git a/drivers/staging/rtl8723bs/hal/sdio_ops.c b/drivers/staging/rtl8723bs/hal/sdio_ops.c
[]
> @@ -191,8 +191,8 @@ static u32 sdio_read32(struct intf_hdl *pintfhdl, u32 addr)
> rtw_hal_get_hwreg(padapter, HW_VAR_APFM_ON_MAC, &bMacPwrCtrlOn);
> if (
> ((deviceId == WLAN_IOREG_DEVICE_ID) && (offset < 0x100)) ||
> - (false == bMacPwrCtrlOn) ||
> - (true == adapter_to_pwrctl(padapter)->bFwCurrentInPSMode)
> + (!bMacPwrCtrlOn) ||
When you do these sorts of conversions can you
please remove the unnecessary parentheses too?
next prev parent reply other threads:[~2017-12-17 9:45 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-12-17 9:35 [PATCH 0/4] Remove checkpatch warnings Shreeya Patel
2017-12-17 9:37 ` [PATCH 1/4] Staging: rtl8723bs: Replace true with x and false with !x Shreeya Patel
2017-12-17 9:45 ` Joe Perches [this message]
2017-12-17 9:51 ` Shreeya Patel
2017-12-17 9:39 ` [PATCH 2/4] Staging: rtl8723bs: Change names to conform to the kernel code Shreeya Patel
2017-12-19 14:29 ` [RFC PATCH] Staging: rtl8723bs: initinterrupt8723bsdio() can be static kbuild test robot
2017-12-17 9:40 ` [PATCH 3/4] Staging: rtl8723bs: Change condition to assignment Shreeya Patel
2017-12-17 9:42 ` [PATCH 4/4] Staging: rtl8723bs: Use !x instead of NULL comparison Shreeya Patel
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1513503952.31581.24.camel@perches.com \
--to=joe@perches.com \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=shreeya.patel23498@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome