From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932749AbcBIQBk (ORCPT ); Tue, 9 Feb 2016 11:01:40 -0500 Received: from mout.kundenserver.de ([212.227.17.13]:49455 "EHLO mout.kundenserver.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755203AbcBIQBf (ORCPT ); Tue, 9 Feb 2016 11:01:35 -0500 From: Arnd Bergmann To: linux-arm-kernel@lists.infradead.org Cc: Brijesh Singh , Suravee Suthikulpanit , mark.rutland@arm.com, devicetree@vger.kernel.org, arm@kernel.org, pawel.moll@arm.com, ijc+devicetree@hellion.org.uk, linux-kernel@vger.kernel.org, robh+dt@kernel.org, leo.duran@amd.com, galak@codeaurora.org, thomas.lendacky@amd.com, brijeshkumar.singh@amd.com Subject: Re: [PATCH V2 09/12] dtb: amd: Add KCS device tree node Date: Tue, 09 Feb 2016 17:00:48 +0100 Message-ID: <15181064.RzzsN4CWec@wuerfel> User-Agent: KMail/4.11.5 (Linux/3.16.0-10-generic; KDE/4.11.5; x86_64; ; ) In-Reply-To: <56BA0A2B.5000705@amd.com> References: <1454954357-8395-1-git-send-email-Suravee.Suthikulpanit@amd.com> <4018438.bPuTyoUuqf@wuerfel> <56BA0A2B.5000705@amd.com> MIME-Version: 1.0 Content-Transfer-Encoding: 7Bit Content-Type: text/plain; charset="us-ascii" X-Provags-ID: V03:K0:PORVZVyXjOloXz/t8QYdcH3kYsy/3sYBUPinm6v/tgtvwu6CuBk vb7uiAfIRv0Bs3wRYFZXSUy9kTTVaHVPxGlv6LLNvPySzn9IsCVDNjsAr7K+DM3tTNvSj/L yyFR/Vy6acRthIzDNMbvtjgvA6I6JS684biVhTFZ6gzo0SksEa4Awhv4gBmLTk7OTpLmrR9 9qD112ya55muaggm97ZwQ== X-UI-Out-Filterresults: notjunk:1;V01:K0:ZAnlPNHiAjk=:Y0neGaGVfK3lBSUoWGdHnC GnzAONzpEeMqzOSX1pxjdabTHUQrf0R1sW3m3kczZlI4AbLy8nXrqXQO6LmqfznTF10mATtPJ AhcAzjvFm4wIz0CFjcmg10gF5BLNoMnPbTgEBHubOnSF/iwuGuepjBOoy3QlM9c7ITmWMspFs nKTEAKdScIqR0BTA3434Ca3IbWojtjEcpXrD36St1x3IePHqF1FHrGDy+3cKzWZxems0JeBN8 6XpjvRz9C3a4DXOtqDgWqjvMJF+1hL+usmRrZ3LvgBTmIxYjU1MYhJDl3kTMStyUMIQRcfoqh 3IEhtAr+TJgjsBCPKPr7x95FFSRl5V22kuXiWs0BreZUqnxl/JQL0oPgUx320D7Nca3HmnR9v D6MP+FWDyoR6P1u4wqT7tXsRBOjMhSGguDI9IntQqKPFYTj6sKfng9GBcJIbHkznSSx7FNT/1 2xeRC2Tt8MSc0RP7pNs3G6pnemg1Ovl56G16i6ieUr39COzTVSlXkF6QdmIPO/nUhAATedIej hXpo8Q011StmUGyuVaCEzuKcSsMwQwdmsd/S0gq3EK+o4THWupu7rQj/3vwAi3Wj5lLhPOtwC jPWaA4Ogq+i0yaEYd4pv0pbTnHz8fxw4Gz6puWHidkIcU+f0IDRrPCaZl+2JKBEvPyyLWt6am t6R9v5pScN7l+nTfQEBBlG8H9dHYYiJCzPsNRex1frO6mV9QdVWv+fKBtGCsm+QAHW2+tQ7f7 0csxJWxMTyQxtH9X Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tuesday 09 February 2016 09:47:55 Brijesh Singh wrote: > > > > I see we don't have a binding file for this, can you add one please? > > > There is binding file ipmi.txt [1]. Am I missing something ? > > [1] http://lxr.free-electrons.com/source/Documentation/devicetree/bindings/ipmi.txt Sorry, my mistake: I was looking for "ipmi_kcs", which is not in there. > > > > Why the strange name for the interrupt? > > > > Now I don't remember the doc but sometime back while implementing BMC on Seattle I saw that interrupt was labeled as "ipmi_kcs" > hence used the same name in DT. But if you want to use different name then let me know the string and will update it. > > Theoretically IPMI system interface supports the following interface and any of these interfaces can be used by > A57 to communicate with BMC: > > * Keyboard controller style (KCS) > * System Management Interface (SMIC) > * Block transfer (BT) > * SMBus system interface (SSIF) > > AMD Seattle platform supports "KCS". > The important part for interrupt/reg/... names is that you must use exactly the names that are listed in the binding. If there is no name in there, it's better not to add the name property. The other point is that "ipmi_kcs" is a name that is picked really badly, as it uses a '_' character while DT properties by convention use '-' between names, and the name of the IRQ is the same as the device itself, which is really not a useful way to disambiguate multiple interrupts in the same device, if someone ever adds another irq line. Arnd